• CONTEST ALERT - Experience the power of DDR5 memory with Kingston Click for details

Graphic Card Problem HD5770

Status
Not open for further replies.

Zangetsu

I am the master of my Fate.
My Card is not working

since yesterday when I boot PC the card LED (green) glows for 1min or less & then turns-off & Red LED glows but the fan of the card keeps spinning

my rest of the components are working fine I can even hear the windows 7 boot sound.but my display is blank bcoz my mobo doesn't have IGP :-(

what should I do? :|
 
Last edited:

pkkumarcool

Game & anime Lover
i meant to say that are u able to surf using ur pc in some way..have u tried to borrow or exchange gfx card from friend to check its gfx card problem only?

go to nearest comp shop and check it this is the best way..
 
OP
Zangetsu

Zangetsu

I am the master of my Fate.
i meant to say that are u able to surf using ur pc in some way..have u tried to borrow or exchange gfx card from friend to check its gfx card problem only?

I can't access my PC.bcoz my Gigabyte mobo doesn't have IGP.
neither I can borrow card frm frnds coz none of my frnd lives nearby :|
 

Cilus

laborare est orare
Then send it for RMA rather than asking here. We can't help you here as tou can't neither test your card to other systems or test another card to your system.
Sapphire RMA service is very good and if your card is damaged then they will replace it.
 
OP
Zangetsu

Zangetsu

I am the master of my Fate.
Then send it for RMA rather than asking here. We can't help you here as tou can't neither test your card to other systems or test another card to your system.
Sapphire RMA service is very good and if your card is damaged then they will replace it.

yes that is main issue I have only option left is RMA...

but can u guys tell me what is red led means here :|
 

pramudit

Gaming hardcore
afaik red light glows when hdd is in use...

your issue is same as my gpu bt my mobo has igp so atleast my computer works....
 

pramudit

Gaming hardcore
then check out gpu website or any manual that came with it, my card had no light so dont know anything...
 

saswat23

Human Spambot
Form the colour i.e Red, one can very well say that the card has some problem. BTW why dont you get the card checked at shop from you bought it?
RMA is the last option for you. Perhaps you will be getting a HD 6770 as replacement. So, RMA it ASAP.
 

topgear

Super Moderator
Staff member
yes that is main issue I have only option left is RMA...

but can u guys tell me what is red led means here :|

It means there' some loose contact between the pci-e slot and the gfx card connector or the gfx card is not getting enough power.

Remove the card from the slot, clean the card and the slot, put them back, check the pci-e 6 pin power connector of the PSu and the gfx card and make sure they are dust free and ok. connect the pci-e power plug and try running the pc.
 
OP
Zangetsu

Zangetsu

I am the master of my Fate.
RMA is the last option for you. Perhaps you will be getting a HD 6770 as replacement. So, RMA it ASAP.

r u sure abt that HD6770 :mrgreen:

It means there' some loose contact between the pci-e slot and the gfx card connector or the gfx card is not getting enough power.

Remove the card from the slot, clean the card and the slot, put them back, check the pci-e 6 pin power connector of the PSu and the gfx card and make sure they are dust free and ok. connect the pci-e power plug and try running the pc.

actually the problem started when I opened the cabinet for cleaning & I had removed the card cleaned it & inserted it back.
the day I cleaned I used the machine for 10~15mins it was working perfectly
but the next day when I started my machine the problem started :|

I will again use the step given by u...

Q: Does static charge damages the card?

I searched TDF & found AcceleratorX had the same problem as mine

http://www.thinkdigit.com/forum/graphic-cards/144800-550-ti-5770-a-2.html

@Skud:

My Sapphire HD 5770 developed the D4000 LED issue, i.e. thermal diode going crazy even though there is no overheating happening. From what I could see on the internet, only Sapphire (the exact same one I had) and HIS models have this problem. There are a variety of fixes, from applying more thermal conducting paste to using a better aftermarket cooler, but in some cases the card was just plain bugged - mine was one such case. The display would go black after 15-30 minutes and the D4000 LED light would come on.

I gave it for RMA and have collected the repaired/replaced unit (I don't know whether Aditya infotech repairs or replaces). In the meantime, however, I got myself a 550 Ti and the system is running fine, so I'm in no mood to check the 5770 at this time. Will however keep the card for possible use in building a PC from spare parts I got.

But given the frequency of this issue, it seems that many Sapphire cards of that particular PCB revision has this problem. It was a non-reference PCB design, should have known better.

I used to think Sapphire was the gold standard for ATI graphics cards, but when a card develops an issue like that in 1.5 years, you don't get a good impression.
 

Tech_Wiz

Wise Old Owl
5770 = 6770 apart from Name Change.

Static Charge can damage any electrical part specially PCBs. So Yes for GFX Card.
 

topgear

Super Moderator
Staff member
r u sure abt that HD6770 :mrgreen:



actually the problem started when I opened the cabinet for cleaning & I had removed the card cleaned it & inserted it back.
the day I cleaned I used the machine for 10~15mins it was working perfectly
but the next day when I started my machine the problem started :|

I will again use the step given by u...

Q: Does static charge damages the card?

I searched TDF & found AcceleratorX had the same problem as mine

http://www.thinkdigit.com/forum/graphic-cards/144800-550-ti-5770-a-2.html

read this :

http://www.overclock.net/t/885790/xfx-hd-5770-d4000-light-red
 
OP
Zangetsu

Zangetsu

I am the master of my Fate.
^^have read that
finally sent for RMA :|
will have to wait 10~15 days max for replacement
I hope sapphire RMA is good :Fingerx:

will post after the results
 
Last edited:
Status
Not open for further replies.
Top Bottom