• CONTEST ALERT - Experience the power of DDR5 memory with Kingston Click for details

Ubuntu 8.04 quotes bug

Status
Not open for further replies.
Hi All

Has anyone else noticed the fact that in Ubuntu hardy heron, there is a bug due to which single and double quites don function properly ? The first time I type them, there is no output. In Konqueror, I end up with two square boxes if I use double quotes twice, in Firefox, I get two small dots, and if I type double quotes before a letter like a, I end up with two dots over it. Single quote becomes another pronounciation symbol in firefox(a comma like dash over the letter), but results in two square boxes again in Konqueror.

I googled for this, and found some entries in ubuntu forums, which is sadly offline due to maintainence issues.

update: I saw this http://64.233.169.104/search?q=cach...+keyboard+quote+bug+double&hl=en&ct=clnk&cd=5 and I hope it works.

another update: UK default results in exchange of " and @ but it solves the problem. But shift+2 gives ", and there are many more such issues.

yet another update: I noticed that for an average iBall keyboard like mine with a big fat ugly enter button, intel 105 key keyboard with US default works fine.(not fully tested)
 
Last edited:

praka123

left this forum longback
I havent faced any problems.may be you have to select correct keyboard language?(US)
 
I used the following command to enable resetting keyboard:
Code:
sudo dpkg-reconfigure -plow console-setup[/quote]
but I am not sure which are the right options. can someone please try this command out and tell me what are the options I must select ?
 

praka123

left this forum longback
well,I dont think that command can help much?I think selecting Xorg kbd type is what is helpful.
first make sure is it a 104 kbd or 102 etc.then ,for eg: for a 104 kbd,in /etc/X11/xorg.conf in"Section "InputDevice" ,keyboard -add below line:
Code:
    Option         "XkbModel" "pc104"
    Option         "XkbLayout" "us"
save,restart X,boot into Gnome,open System>preferences>keyboard>layout>generic 104 ,and tick "US" as lang.that will hopefully fix.

below is my debian xorg.conf for example:
Code:
Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc104"
    Option         "XkbLayout" "us"
EndSection
REMEMBER:ubuntu or fedora or any latest distros autoconfigures X now.so xorg.conf is minimal.you have to configure it .
 
well,I dont think that command can help much?I think selecting Xorg kbd type is what is helpful.
first make sure is it a 104 kbd or 102 etc.then ,for eg: for a 104 kbd,in /etc/X11/xorg.conf in"Section "InputDevice" ,keyboard -add below line:
Code:
    Option         "XkbModel" "pc104"
    Option         "XkbLayout" "us"
save,restart X,boot into Gnome,open System>preferences>keyboard>layout>generic 104 ,and tick "US" as lang.that will hopefully fix.

below is my debian xorg.conf for example:
Code:
Section "InputDevice"
    Identifier     "Generic Keyboard"n
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc104"
    Option         "XkbLayout" "us"
EndSection
REMEMBER:ubuntu or fedora or any latest distros autoconfigures X now.so xorg.conf is minimal.you have to configure it .
if I select keyboard in gnome, the setting is not forwarded to IceWM or KDE. Thats the problem.

I want to reset my install time selection. And I need to find a way to do that.

I can´t continue my programming course if I cant use quotes.
 
Status
Not open for further replies.
Top Bottom