Tried everything I know...Still can't able to FORMAT pen drive

I am using Sandisk 32GB Cruzer Blade.
Can't able to format pen drive, getting write protected error (There is no switch of write protection on pen drive)

1) Kaspersky detecting Trojan but can't able to delete it.
2) Malware bytes not detecting any threat.
3) Changing driver letter method not working
4) Registry write protection (Hexadecimal 0) method not working.
5) G.Policy editor method not working.
6) Command prompt format command not working


What should I do to DELETE the threat detected and FORMAT the pen drive?
 

rickenjus

In the zone
have you tried force formatting in disk management.

Control Panel -> Administrative Tools -> Computer Management -> disk Management
 

Vyom

The Power of x480
Staff member
Admin
You can try try Linux Live disk (like ubuntu) or in Windows Safe mode (by pressing F8 before it starts booting).
It is obviously some malware that is accessing your pen drive, not allowing it to get unmounted so that you can format it.
 

Flash

Lost in speed
Then, delete the partitions if any and format the pen drive as a whole in disk management itself.
 

dashing.sujay

Moving
Staff member
Sadly, nothing will work.

I too have a pen drive lying with same condition. Tried everything available on internet.

Just get it replaced if warranty is left.
 
Top Bottom