Linux Installation Problem!

Discussion in 'Open Source' started by monkey, Dec 5, 2006.

Thread Status:
Not open for further replies.
  1. monkey

    monkey Member

    Joined:
    Aug 4, 2006
    Messages:
    656
    Likes Received:
    1
    Trophy Points:
    18
    I have been using Linux for quiet some years (Dual boot system: Win Xp and Linux). I recently saw an article on virtualisation using VMwizard and VMPlayer and thought of giving it a try. But after installation I found that combining Windows and linux was not easy and thus thought of reverting back to my old dual boot system. But after restarting the computer I was shown the Grub bootloader (which i had installed during virtualisation try). To remove it I used FIXMBR option from my Win Xp CD. I then proceeded to format the partition where I had installed the virtual machine.
    Later when I tried to reinstall Suse Linux 10.1 on this dedicated partition everything went smoothly until linux tried to set the Time. At this point the hard disk started to work as if finding it difficult to search something. It went on for 30 minutes before I thought of restarting the computer and try 64-bit Suse 10.1 instead. But then again the same problem occured during time-zone setting. I tried with my older Suse 10.0 DVD but no solution.
    What has gone wrong?
     
  2. vignesh

    vignesh New Member

    Joined:
    Jul 20, 2004
    Messages:
    1,658
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Chennai
    Your question is to messy... Be more clear.. Do you get any error message.. Try switching to an VC using Alt+F1 to F6 and check for errors
     
  3. OP
    OP
    monkey

    monkey Member

    Joined:
    Aug 4, 2006
    Messages:
    656
    Likes Received:
    1
    Trophy Points:
    18
    Well Vignesh, after trying virtualisation I wanted to turn back to my old dual boot system. For this I had removed virtual machine and all associated files. I had also used FIXMBR from Win XP CD to correct MBR which had changed during my virtualisation trial.
    Its is during fresh installation of Suse that I faced the problem. Like said earlier after the message "loading cataloges" under system anaysis step the installation pointer on the left moves to "Time zone setting". It is at this point that my computer gets hung. Only the mouse and HDD works with HDD working furiously as if to find something. Nothing else happens no matter what button or key I press. Only thing out is to reset the machine.
     
  4. vignesh

    vignesh New Member

    Joined:
    Jul 20, 2004
    Messages:
    1,658
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Chennai
    Switch to a virtual console and see the error messages and post it here..
     
  5. OP
    OP
    monkey

    monkey Member

    Joined:
    Aug 4, 2006
    Messages:
    656
    Likes Received:
    1
    Trophy Points:
    18
    U r not getting me Vignesh! There is no virtual console now and there r no error messages. The system just stops responding and is caught-up in some sort of cycle.
     
  6. QwertyManiac

    QwertyManiac Commander in Chief

    Joined:
    Jul 17, 2005
    Messages:
    6,656
    Likes Received:
    10
    Trophy Points:
    0
    Its some partition table error I guess. Give us an o/p of your HDD partitioning by passing 'fdisk -l' in the *nix terminal.
     
  7. OP
    OP
    monkey

    monkey Member

    Joined:
    Aug 4, 2006
    Messages:
    656
    Likes Received:
    1
    Trophy Points:
    18
    I have 160 GB HDD divided into 5 partitions. First 3 partitions are formated in NTFS and 4th partition in FAT32 (for windows and linux to be able to gain full rights to it). 5th partition is not formated and is meant for linux installation only. On using "fdisk -l" in linux (I used rescue mode after booting from Linux CD), I got the following:

    Disk /dev/sda: 160.0 GB, 160041885696 bytes
    255 heads, 63 sectors/track, 19457 cylinders
    Units=cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 3048 24483028+ 7 HPFS/NTFS
    /dev/sda2 3049 19457 131805292+ f W95 Ext'd (LBA)
    /dev/sda5 3049 9132 48869698+ 7 HPFS/NTFS
    /dev/sda6 9133 13392 34218418+ 7 HPFS/NTFS
    /dev/sda7 13393 14738 10811713+ b W95 FAT32
    /dev/sda8 14739 19457 37905336 6 FAT16

    QwertyManiac, can u find anything wrong in this?
     
  8. Satissh S

    Satissh S New Member

    Joined:
    Mar 23, 2005
    Messages:
    692
    Likes Received:
    2
    Trophy Points:
    0
    Location:
    Chennai , India
    hmm... AFAIK the problem has occured when it tried to run, ntpdate. Try removing ntpdate from the default/boot runlevel.
    I dont know exactly how's it in SuSE.. i _think_ the init scripts may be in /etc/rc.d . I'm not sure, may be /etc/init.d too. You have to rename ntpd script to something else or maybe (better idea) post the contents of that script here.
    I dunno whats in Suse, we use rc-update in gentoo to change (add/remove) the boot scripts.
    Besides, you said that hard disk spins vigorously while trying to "Set Time".. hmm. I'am not sure (attack?! :?) about this.
    Anyways, you can run this to set time manually, afterwards.
    Code:
    ntpdate -u -b pool.ntp.org
     
  9. techtronic

    techtronic I Always Prefer 1080p

    Joined:
    May 22, 2006
    Messages:
    1,018
    Likes Received:
    13
    Trophy Points:
    0
    Normally,when FIXMBR command is executed, a fresh MBR is created
    So it removes the existing entries in the MBR
    The configuration made by the GRUB to the MBR would not be valid after executing FIXMBR command
     
  10. eddie

    eddie El mooooo

    Joined:
    Jan 26, 2006
    Messages:
    1,414
    Likes Received:
    14
    Trophy Points:
    0
    Location:
    India
    Check your BIOS and see if your time settings are right. Also, if you use LAN, then disconnect your LAN wire. It seems that some how your BIOS is giving wrong time information and installation procedure is trying to correct that.
     
  11. Satissh S

    Satissh S New Member

    Joined:
    Mar 23, 2005
    Messages:
    692
    Likes Received:
    2
    Trophy Points:
    0
    Location:
    Chennai , India
    @eddie: isn't it trying to synchronize time with ntp server? The lag is always there, isn't it?
     
  12. OP
    OP
    monkey

    monkey Member

    Joined:
    Aug 4, 2006
    Messages:
    656
    Likes Received:
    1
    Trophy Points:
    18
    Time in BIOS is OK. My Win XP is showing no problem too with time and date (it would have been if there was something wrong with BIOS timing). I tried installing Linux with LAN cable disconnected. No success. Sync lag shud be OK but 40 minutes without any o/p is not.
     
  13. Satissh S

    Satissh S New Member

    Joined:
    Mar 23, 2005
    Messages:
    692
    Likes Received:
    2
    Trophy Points:
    0
    Location:
    Chennai , India
    thats why i said, boot in rescue mode and remove/rename that script and post it here.
     
  14. vignesh

    vignesh New Member

    Joined:
    Jul 20, 2004
    Messages:
    1,658
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Chennai
    Just don`t configure your lan card or modem during installation.
     
  15. OP
    OP
    monkey

    monkey Member

    Joined:
    Aug 4, 2006
    Messages:
    656
    Likes Received:
    1
    Trophy Points:
    18
    Vignesh, I don't configure LAN/Modem as never reach that step during installation. The step where I get stuck is way before.

    Satissh, can u please tell me how to remove/rename and post the script after I login in rescue mode as root? I m not very familiar with linux commands (I use it for basic purposes only :-l )
     
  16. Satissh S

    Satissh S New Member

    Joined:
    Mar 23, 2005
    Messages:
    692
    Likes Received:
    2
    Trophy Points:
    0
    Location:
    Chennai , India
    :| I'm not very much into suse, ofcourse you can find that ntpd script in /etc/init.d or /etc/rc.d/ . I am not sure, anyways just use mv command to rename the file
    Code:
    mv file1 file2
    changes name of file 1 to file 2. Thats just a cheap way to do it. There must be some better way to manage startup scripts in SuSE.
     
  17. OP
    OP
    monkey

    monkey Member

    Joined:
    Aug 4, 2006
    Messages:
    656
    Likes Received:
    1
    Trophy Points:
    18
    Boss, there is no /etc as there is no linux installed.
     
  18. Satissh S

    Satissh S New Member

    Joined:
    Mar 23, 2005
    Messages:
    692
    Likes Received:
    2
    Trophy Points:
    0
    Location:
    Chennai , India
    huh. Then install it first. I cant understand a thing from what you are saying. You said earlier that you had SuSE installed.. didn't you?
     
  19. techuptodate

    techuptodate New Member

    Joined:
    Dec 14, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
  20. OP
    OP
    monkey

    monkey Member

    Joined:
    Aug 4, 2006
    Messages:
    656
    Likes Received:
    1
    Trophy Points:
    18
    OK, I'll explain in brief again:
    1. I HAD Suse 10.0 and my system was dual boot With Win XP
    (covering 4 partitions) and Linux.

    2. I wanted to try virtualisation using VMWizard and VMPlayer for which I removed my existing Suse.

    3. I didn't like virtualisation - so I uninstalled it and removed virtual machine.

    4. Tried installing Suse back so as to be like old Dual Boot System.

    5. It is here that installation of linux failed. I tried Suse 10.0, Suse 10.1 and Fedora Core 4 & 6. Nothing worked and all installation failed.
     
Thread Status:
Not open for further replies.

Share This Page