ubuntu help please.... hotplug problem....

Discussion in 'Open Source' started by santu_29, Apr 18, 2006.

Thread Status:
Not open for further replies.
  1. santu_29

    santu_29 New Member

    Joined:
    Jun 21, 2005
    Messages:
    232
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    Delhi
    i just installed ubuntu 5.10, after installation it asked me to remove any cd as the system was going to reboot. the system restarted, grub worked fine, then came the ubuntu screen and below that the processes, starting from 'loading modules'. but when it came to 'loading hotplug subsystem' it stuck, it remained there for around 1/2 an hour and then i restarted the system. i tried again but it stuck at the same point. why is this happening. please help. :cry:

    my system
    p4 2.4, 512 ram, agp geforce 6200, asrock 845 chipset motherboard
     
  2. baccilus

    baccilus Active Member

    Joined:
    Feb 28, 2006
    Messages:
    1,189
    Likes Received:
    4
    Trophy Points:
    38
    Location:
    Chandigarh
    Hi Santu. This happens due to incompatible hardware, either due to sound card or graphic card. Now try doing this- disable your sound card from BIOS and then boot. If this doesn't work, boot from your onboard graphic card rather than the Geforce 6200.This can be done from BIOS too. Just keep pressing DEL key whiile you power up your system. Once you are able to boot, you can look around for the respective drivers and all. Problem solved. Keep me updated on this.
     
  3. OP
    OP
    santu_29

    santu_29 New Member

    Joined:
    Jun 21, 2005
    Messages:
    232
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    Delhi
    yep its the graphics card and yed, if i remove the agp and plug in the monitor into the onboard graphics, it works, but then i cant leave the agp. i have downloaded the latest drivers but then you need the os to run in order to install them, hah...., i even tried the resque mode and that too failed to boot the system. what now..... :oops:
     
  4. ujjwal

    ujjwal New Member

    Joined:
    Dec 1, 2003
    Messages:
    780
    Likes Received:
    0
    Trophy Points:
    0
    Try booting with the "nohotplug" parameter, that is, select the Ubuntu entry in your GRUB OS selection menu, press 'e' to edit it, add "nohotplug" to the end of the entry and boot. Now you should be able to boot into ubuntu, though you will not have automatic hardware detection.

    To enable hotpluggin, you should figure out which device causes hotplug to crash and add it to the blacklist.
     
  5. Satissh S

    Satissh S New Member

    Joined:
    Mar 23, 2005
    Messages:
    692
    Likes Received:
    2
    Trophy Points:
    0
    Location:
    Chennai , India
    hmm.. this is a known bug.. in the kernel 2.6 arch.. Due to asrock 's patented AGI technology, you get this hotplug error with ubuntu, suse etc., and fedora udev will cause kernel panic.
    A neat work around for this problem is :p
    either quickly press [ctrl]+C when it says
    starting hotplug subsystem.. [ok]
    but u'll need to be quick at that. Now when you boot into the system execute.
    Code:
    $ sudo mv /etc/init.d/hotplug.sh /etc/init.d/hotplug_null.sh 
    (press tab to autocomplete). I know this is a cheap way, but it's also simple :p
    now hotplug wont start and probably u'r sound card wont get detected though :|
    you can however compile and install a 2.4 series kernel and continue using hotplug normally.. which i think works. (just a guess)
     
Thread Status:
Not open for further replies.

Share This Page