• CONTEST ALERT - Experience the power of DDR5 memory with Kingston Click for details

Sound Stops after some seconds in Gutsy

Status
Not open for further replies.

Rahim

Married!
Hi guys, again i am having a problem.WHile i play mp3 in Exaile it plays for a while and then sound dies but song continues to play. If i click next then Exaile freezes.If i leave it that way after 3-4 minutes the next song is played.
This freezing continues to happen in VLC, Totem, XIne,Mplayer etc.
This is the output from Terminal
Code:
rahim@SEBA:~$ exaile 
Plugins 'Mini Mode' version '0.4.6' loaded successfully
Plugins 'Shoutcast Radio' version '0.4.5' loaded successfully
Plugins 'Tray Buttons' version '0.7.2' loaded successfully
Plugins 'Mass Storage Driver' version '0.3.4' loaded successfully
Plugins 'Global Hotkeys' version '0.6.2' loaded successfully
Plugins 'Sound Juicer' version '0.1.3' loaded successfully
Plugins 'Desktop Cover' version '0.3.3' loaded successfully
Created db for thread Thread-1
{'Thread-1': <sqlite3.Connection object at 0x88ec890>}
Using multimedia keys from: gnome
Starting scan timer at 30.0
loading tracks...
Closed db for thread Thread-1
done loading tracks...
loading songs
Clearing tracks cache
Importing /home/rahim/.exaile/saved/playlist0001.m3u
Importing /home/rahim/.exaile/saved/playlist0000.m3u
Importing /home/rahim/.exaile/saved/playlist0002.m3u
Last playlist loaded
Loading page 1
sh: jackd: not found
ReplayGain support initialized.
next track was reported as  Chura Liya Hai Tum Ne.mp3 from Old Classic Hits by Md Rafi Kishore da Asha Lataji
sh: jackd: not found
updated plays 1, rating -1
updated plays 1, rating 1
next track was reported as  None
sh: jackd: not found
sh: jackd: not found
next track was reported as   Rangeela Re from Rangeela (1995) by Asha Bhosle & Aditya Narayan
sh: jackd: not found
updated plays 1, rating -1
I use gstreamer.
Plz help.
DO i have to re-install Gutsy all over again?
 
OP
Rahim

Rahim

Married!
@qwerty , DIdnt work. The sound still dies:(
Getting this error
Code:
JACK tmpdir identified as [/dev/shm]
 

praka123

left this forum longback
^this,seems to me like you have not enabled esd completely? "run" "gstreamer-properties" and enable ESD,and select ESD for most options and test to make sure it works.yes,that loong beeep! :p

If not working,
I think you need to add the necessary ALSA/OSS modules in /etc/modules file for boot time loading.

May be u can post here the o/p of lspci ?we will try to help you :)
 
OP
Rahim

Rahim

Married!
^ Never mind.
Praka bhai the error started when i did routine update and package was libpulseaudio . I downgraded that to previous version and rebooted but that error continues to happen.
For selecting ESD, you mean by going to Preferences>Sounds, right?:cool:
 

praka123

left this forum longback
make sure /etc/esound/esd.conf is:
Code:
  [esd]
# autospawning is not recommended, since it can't really be done
# right.  If you want your login session to be using a sound daemon,
# you should start it from the session controller, not some random
# app inside.
auto_spawn=1
spawn_options=-terminate -nobeeps -as 2
spawn_wait_ms=100
# default options are used in spawned and non-spawned mode
default_options=

and delete ~/.gstreamer-0.10 u can run below command safely:
Code:
 rm -rf ~/.gstreamer-0.10 && rm -rf ~/.dbus
then
Code:
sudo telinit 1
when system reaches runlevel 1,press CTRL+D to boot with runlevel2.check if this works.
 
OP
Rahim

Rahim

Married!
O?P of lspci rahim@SEBA:~$ lspci
00:00.0 Host bridge: Intel Corporation 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub Interface (rev 01)
00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 81)
00:1f.0 ISA bridge: Intel Corporation 82801DB/DBL (ICH4/ICH4-L) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801DB (ICH4) IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 01)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
01:08.0 Ethernet controller: Intel Corporation 82801DB PRO/100 VE (LOM) Ethernet Controller (rev 81)

Sorry praka but it didnt work:( and sorry about the formatting as it makes a comfortable reading.
 

praka123

left this forum longback
^@raim:run in terminal "sudo update-pciids" and see lspci details for audio controller.
now,
edit /etc/modules file as sudo.enter below lines as it is and restart the system.
Code:
snd
snd_hwdep
snd_intel8x0
snd_ac97_codec
snd_pcm_oss
snd_pcm
snd_mixer_oss
snd_seq_oss
snd_rawmidi
snd_seq
snd_timer
snd_seq_device
^I think still sound fades off,it is alsa/esound which is creating problems.
make sure,u have all major gstreamer plugins-0.10 installed as exaile etc depends upon gstreamer.make sure esound,esound-common,libasound2,libasound2-plugins,libesd-alsa0 are installed.
now,
run "gstreamer-properties" as local user and select all "ESD" and go to telinit 1 as above and boot into the system.

edit:
and have a look at the gstreamer plugins which I have on my Debian system.do try to install below packages.
gstreamer0.10-alsa
gstreamer0.10-plugins-base
gstreamer0.10-esd
gstreamer0.10-plugins-base-apps
gstreamer0.10-ffmpeg-full
gstreamer0.10-plugins-good
gstreamer0.10-fluendo-mp3
gstreamer0.10-plugins-really-bad
gstreamer0.10-fluendo-mpegdemux
gstreamer0.10-plugins-ugly
gstreamer0.10-fluendo-mpegmux
gstreamer0.10-pulseaudio
gstreamer0.10-gl
gstreamer0.10-tools
gstreamer0.10-gnomevfs
gstreamer0.10-x
gstreamer0.10-lame
gstreamer0.10-pitfdll
 
OP
Rahim

Rahim

Married!
Didnt solve it:( No Luck.
UPDATE: All audio players seems to hang and crash, but in Audacious when it hangs i am able to click next and the next song is played, quite strangely sometimes i am able to play the whole song in Audacious without any hiccups.
What is happening. Its been fine for the last 2 months and now suddenly it down.
Is it time to re-install Gutsy or maybe switch to Debian/Mint? praka bhai help me make my mind.
 
Last edited:

praka123

left this forum longback
@rahim:I hope ur running on a 32-bit intel system.do one thing,install
linux-image-2.6.22-14-386
^along with the needed dependencies.now try and reply.
also,I think there is no need to reinstall.just "sudo apt-get install --reinstall packagename" will do.
packages to be reinstalled includes,alsa-base,alsa-utils,libasound2-plugins,linux-sound-base,alsa-oss etc.
after that,do a "sudo dpkg-reconfigure linux-sound-base" and select ALSA.
 
OP
Rahim

Rahim

Married!
Is there a way to remove all sound related thing and start all over again without reinstalling the system?
ANy reason why this happens?
This problem should have happened when i installed Gutsy 2 months back, isnt it? Why now?
 
OP
Rahim

Rahim

Married!
Thanks a lot Prakash Bhai. I removed & reinstalled all the packages mentioned and no hiccups in sound even in old kernel.

Suggestion to Mods: Should give an option to "Mark This Thread as Solved" as in UF.
 
Status
Not open for further replies.
Top Bottom