seasonic s12 ii 620w wony boot

niz04

Journeyman
i have a gigabyte g41m combo mobo xeon x3220 proccy and 4 gb ram..i bought
seasonic 620w but it wont boot because of missing -5v white wire. i tried jump start my psu. it work. please guys help to start my pc
 
OP
N

niz04

Journeyman
my psu dont have 17 no. pin which is gnd. without than pin my pc wont boot ..i check the psu is ok ...is thier any way to use some pin and start my pv
 

The Sorcerer

oh wow...Xenforo!!!
That's because they were removed from power supplies with atx12v spec version 1.3 and above. Seasonic 620 is based on v 2.3. Pretty sure that 17th pin was also made for 20 pin power supplies- the psu for very VERY VERY old systems. That is not the reason why the system is not starting.

To check if the power supply is able to power up on its own, follow these instructions exactly:
How To: Jump Start A Power Supply (PSU) / Test A Power Supply And Components

If the fan on the psu or if you've connected any on the the psu spins, that means that the power supply is able to supply power. If it doesn't, rma the power supply. If it does, we can rule out the power supply for the time being.
 
OP
N

niz04

Journeyman
yes psu worked and fan moved for some secend and then stop...but pc wont start. is their any way to start my pc

do i need to power on the psu when i do the trick...when i power off then do the trick then psu fan moves for sec and then stop
 

The Sorcerer

oh wow...Xenforo!!!
^^ Didn't you tell me via PM that you tried the step I suggested above and the power supply didn't work?
 
Top Bottom