• CONTEST ALERT - Experience the power of DDR5 memory with Kingston Click for details

KDE not starting up on boot

Not open for further replies.


Resistance is Futile.
hey there, I shifted to openSUSE 11 & KDE 4.1 recently, while till yesterday everything was working fine. Now all of a sudden, on booting, I get a console login. The system *does* goto run level 5, though. after logging in, I've to issue a startx for KDE to start.

Now the here it gets weirder

1. On issuing startx I get auto-logged in, even though I have auto-login disabled (I *did* have it enabled previously, afterwards I've disabled it)

2. The DE to which I get booted into is random - sometimes its KDE4.1, sometimes its KDE 3.5.9, sometimes its Gnome, although I didn't choose to install KDE 3.5.9 OR Gnome, prolly got isntalled because of some dependencies ? :-/ I have no idea.

3. Even on the rare occasions that I do get a KDE4.1 bootup, I plasma crashes with a sigsev

I tried removing .kde and .kde4 directories in /home but makes no difference

Any suggestions on
(1) How to get the GUI without having to issue startx?
(2) Ensuring that KDE 4.1 is what starts up ?

EDIT: Seems like KDE4.1 is starting, plasma doesn't load, when I issue plasma & at terminal, plasma gets loaded with widgets, ie, with the second Application launch bar and all:
here's a pic

Upon checking kdm.log seems kdmgreet is crashing, here's /var/log/kdm.log
This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.

X.Org X Server
Release Date: 5 September 2007
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux sathya #1 SMP 2008-06-07 01:55:22 +0200 i686
Build Date: 07 June 2008  12:37:27AM

        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Aug 22 11:02:30 2008
(==) Using config file: "/etc/X11/xorg.conf"
(II) Module "ramdac" already built-in
Synaptics DeviceInit called
SynapticsCtrl called.
Synaptics DeviceOn called
Could not init font path element /usr/share/fonts/TTF/, removing from list!
Could not init font path element /usr/share/fonts/OTF, removing from list!
Driver not XRANDR 1.2 capable, ignoring DISPLAYMANAGER_RANDR_MODE_* settings
KCrash: Application 'kdmgreet' crashing...
Synaptics DeviceOff called


Commander in Chief
What's the result? I have no KDE-3.5.x libs installed (Just GTK2 and KDE-4.x/9999 libs), so I can't exactly figure out what might be causing both of them to run, crash and burn...

Also, check out the other .<file|folder>s on the $HOME and remove anything unnecessary/might belong to KDE3. My .kde/ is ln'd to .kde4/, though I have a .kde3.5 too (Think it came with a previous merge, haven't deleted it though), its not the active one. Could you try changing the link and see as well? Maybe KDE4 is reading it all wrong?


Resistance is Futile.
Opensuse 11.0 ships with KDE 4.0.4.

yup, and I've upgraded to KDE 4.1.1 using the 1-click install

@Qwerty havent done it yet, since a reinstall of kdm related packages means that I'll have to d/l from the net and my data card doesnt work in Linux. (I'd done the upgrade using BSNL BB conn, when I was back home on vacation). Will be trying it soon as I switch to Plug2Surf, which might be this weekend.

And the only "k" related . files were .kde and .kde4 deleting both had no effect. Will see if changing the link will have any effect.


Resistance is Futile.
Hey there. Well good news is that I've fixed the kdm_greet crashing issue, while going through the startup logs in YaST(God bless it!!) I found this particular entry
 kdm_greet crashes with code 125 signal 0
A quick Google search for "kdm code 125" gave me this page as 3rd result which mentions,
kdm was working perfectly until ... kdm_greet crashes with code 125 ??? signal 0 after debugging with gdb, I find that findfont from xfree called by qt was in
cause. Then I made a fc-cache and all worked perfectly
So I do a fc-cache in console, restart and BINGO! No more crashes!!
One problem still remaims - it's booting into KDE 3.5.9 instead of KDE 4.1!
I had a look at /etc/X11R6/xinit/xinitrc.common which calls the startkde script
The startkde script loads KDE4.1 :| Besides there's a separate starkde3 script.
So any pointers on how to get KDE 4.1 starting ?

EDIT: .kde is not linked to .kde4
Last edited:
Not open for further replies.
Top Bottom