Help Knoppix Hard disk Install

Discussion in 'QnA (read only)' started by technoteen, Dec 5, 2004.

Thread Status:
Not open for further replies.
  1. technoteen

    technoteen New Member

    Joined:
    Oct 9, 2004
    Messages:
    149
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Nagpur
    hi guys
    i installed knoppix 3.4 on my hard disk
    it has loaded lilo as the boot loader,
    now when i go to knoppix i see all the initial steps then the screen goes black with out of frquency message,even ctrl + alt + f1 gets me the same screen
    i know that the error is due to the wrong config of xf86 - which was not asked for during installation , but please get me out of it
     
  2. OP
    OP
    technoteen

    technoteen New Member

    Joined:
    Oct 9, 2004
    Messages:
    149
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Nagpur
    i am even not able to write to my linux partition from knoppix cd, i am able to write to a fat32 partition
     
  3. GNUrag

    GNUrag FooBar Guy

    Joined:
    Jun 22, 2004
    Messages:
    1,246
    Likes Received:
    5
    Trophy Points:
    0
    Location:
    Interwebs
    Reconfigure your XF86config by any of one the two methods.
    1) # xf86config
    this menu driven script will rewrite your x config file with a new one that you choose. This is the best option, and i have saved many people's lives with this...

    2) # dpkg-reconfigure xserver-xfree86
    Reconfigure your debian packages that belong to xserver

    Use this to mount your ext3 partitions.
    $ su
    # mount -t ext3 -o rw /dev/hda6 /mnt/hda6

    Or better you can make changes in /etc/fstab and make the entries in 4th column from ro to rw
     
  4. OP
    OP
    technoteen

    technoteen New Member

    Joined:
    Oct 9, 2004
    Messages:
    149
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Nagpur
    thanks for the reply but i have already solved both the problems, so moderators can lock this thread
    i used the super user mode in Knoppix cd to gain access to the already mounted as rw reiser partition. there i changed the frequency range in the xf86config-4 file and then my knoppix was booting properly
     
Thread Status:
Not open for further replies.

Share This Page