error:installing using 'apt-get' in ubuntu

Discussion in 'Open Source' started by gary4gar, Jun 13, 2006.

Thread Status:
Not open for further replies.
  1. gary4gar

    gary4gar GaurishSharma.com

    Joined:
    May 21, 2005
    Messages:
    4,094
    Likes Received:
    24
    Trophy Points:
    0
    Location:
    Jaipur
    i was tring to install vlc & codecs using sudo apt-get as someone told me that it is the easiest way to avoid depencies.but i faced a errors.first for vlc.i isued a command
    Code:
    sudo apt-get install vlc
    and i recieved the following depencies probs
    Code:
    [B]sudo apt-get install vlc[/B]
    Reading package lists... Done
    Building dependency tree... Done
    You might want to run `apt-get -f install' to correct these:
    The following packages have unmet dependencies:
      linux-image-2.6.12-9-386: Depends: initramfs-tools (>= 0.17) but it is not going to be installed
      vlc: Depends: liba52-0.7.4 but it is not going to be installed
           Depends: libavahi-client3 (>= 0.6.0) but it is not going to be installed
           Depends: libavahi-common3 (>= 0.6.9) but it is not going to be installed
           Depends: libcdio6 but it is not going to be installed
           Depends: libdbus-1-2 (>= 0.60) but it is not going to be installed
           Depends: libdc1394-13 but it is not going to be installed
           Depends: libdvbpsi4 but it is not going to be installed
           Depends: libfreetype6 (>= 2.1.10-1) but 2.1.7-2.4ubuntu1 is to be installed
           Depends: libfribidi0 (>= 0.10.7-1) but 0.10.5-2 is to be installed
           Depends: libgcc1 (>= 1:4.0.2) but 1:4.0.1-4ubuntu9 is to be installed
           Depends: libgcrypt11 (>= 1.2.2) but 1.2.1-3 is to be installed
           Depends: libgnutls12 (>= 1.2.5) but it is not going to be installed
           Depends: libgpg-error0 (>= 1.1) but 1.0-1 is to be installed
           Depends: libid3tag0 (>= 0.15.1b) but it is not going to be installed
           Depends: libiso9660-4 but it is not going to be installed
           Depends: libmad0 (>= 0.15.1b) but it is not going to be installed
           Depends: libmodplug0c2 (>= 1:0.7-4.1) but it is not going to be installed
           Depends: libmpeg2-4 but it is not going to be installed
           Depends: libogg0 (>= 1.1.3) but 1.1.2-1 is to be installed
           Depends: libstdc++6 (>= 4.0.2-4) but 4.0.1-4ubuntu9 is to be installed
           Depends: libsysfs2 but it is not going to be installed
           Depends: libtar but it is not going to be installed
           Depends: libvcdinfo0 (> 0.7.23) but it is not going to be installed
           Depends: libvorbis0a (>= 1.1.2) but 1.1.0-1ubuntu1 is to be installed
           Depends: libvorbisenc2 (>= 1.1.2) but 1.1.0-1ubuntu1 is to be installed
           Depends: libxml2 (>= 2.6.24) but 2.6.21-0ubuntu1 is to be installed
           Depends: wxvlc but it is not going to be installed
           Depends: vlc-plugin-alsa but it is not going to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    
    and i choose to install codecs tried the following command
    Code:
    sudo apt-get install gstreamer0.8-plugins
    
    recieved the following error
    Code:
    Reading package lists... Done
    Building dependency tree... Done
    The following extra packages will be installed:
      brltty brltty-x11 cpp-4.0 cupsys-driver-gutenprint gcc-4.0-base gcj-4.0-base
      gconf2 gconf2-common gij-4.0 grepmap gstreamer0.8-a52dec gstreamer0.8-aa
      gstreamer0.8-alsa gstreamer0.8-artsd gstreamer0.8-audiofile
      gstreamer0.8-caca gstreamer0.8-cdio gstreamer0.8-cdparanoia gstreamer0.8-dv
      gstreamer0.8-dvd gstreamer0.8-esd gstreamer0.8-festival gstreamer0.8-flac
      gstreamer0.8-gnomevfs gstreamer0.8-gsm gstreamer0.8-gtk gstreamer0.8-hermes
      gstreamer0.8-jpeg gstreamer0.8-mad gstreamer0.8-mikmod gstreamer0.8-misc
      gstreamer0.8-mms gstreamer0.8-mpeg2dec gstreamer0.8-musepack
      gstreamer0.8-oss gstreamer0.8-plugin-apps gstreamer0.8-sdl gstreamer0.8-sid
      gstreamer0.8-speex gstreamer0.8-swfdec gstreamer0.8-theora
      gstreamer0.8-tools gstreamer0.8-vorbis gstreamer0.8-x klibc-utils
      liba52-0.7.4 libartsc0 libasound2 libatspi1.0-0 libavahi-client3
      libavahi-common-data libavahi-common3 libavahi-glib1 libbonobo2-0
      libbonobo2-common libbrlapi1 libcairo2 libcdio6 libcupsys2
      libcupsys2-gnutls10 libdbus-1-2 libdbus-glib-1-2 libfreetype6 libgcc1
      libgcj6 libgconf2-4 libgcrypt11 libglib2.0-0 libglib2.0-data libgnomeui-0
      libgnomeui-common libgnomevfs2-0 libgnomevfs2-common libgnutls12
      libgpg-error0 libgstreamer-gconf0.8-0 libgstreamer-plugins0.8-0
      libgstreamer0.8-0 libgutenprint2 libid3tag0 libklibc libmad0 libmikmod2
      libmms0 libmpeg2-4 libogg0 liboil0.3 libopencdk8 libpango1.0-0
      libpango1.0-common libreadline4 libreadline5 libselinux1 libsepol1
      libsidplay1 libssl0.9.8 libstdc++6 libswfdec0.3 libsysfs2 libtasn1-2
      libvorbis0a libvorbisenc2 libwavpack0 libxml2 lsb-base module-init-tools
      python2.4-dbus readline-common wpasupplicant
    Suggested packages:
      libbrlapi1-dev festival brltty-flite gcc-4.0-locales gutenprint-doc
      gutenprint-locales gcj-4.0 libgcj6-awt libasound2-plugins libfreetype6-dev
      rng-tools libgnomevfs2-bin gnutls-bin ttf-thryomanes sidplay-base xsidplay
      libengine-pkcs11-openssl
    Recommended packages:
      gnome-gv postscript-viewer libgcj6-jar libgnomevfs2-extra libtasn1-2-bin
    The following packages will be REMOVED:
      dbus dbus-1-utils gnome-volume-manager hal hal-device-manager hotplug
      hwdb-client ifrename initramfs-tools linux-386 linux-image-2.6.12-9-386
      linux-image-386 linux-restricted-modules-2.6.12-9-386
      linux-restricted-modules-386 ubuntu-desktop ubuntu-minimal udev
      update-notifier usplash
    The following NEW packages will be installed:
      brltty brltty-x11 cupsys-driver-gutenprint gcj-4.0-base gconf2-common
      gstreamer0.8-a52dec gstreamer0.8-aa gstreamer0.8-artsd gstreamer0.8-caca
      gstreamer0.8-cdio gstreamer0.8-festival gstreamer0.8-gtk gstreamer0.8-mad
      gstreamer0.8-mikmod gstreamer0.8-mms gstreamer0.8-mpeg2dec
      gstreamer0.8-plugins gstreamer0.8-sid gstreamer0.8-swfdec liba52-0.7.4
      libatspi1.0-0 libavahi-client3 libavahi-common-data libavahi-common3
      libavahi-glib1 libbrlapi1 libcdio6 libcupsys2 libdbus-1-2 libdbus-glib-1-2
      libgnutls12 libgutenprint2 libid3tag0 libmad0 libmikmod2 libmms0 libmpeg2-4
      libsepol1 libsidplay1 libssl0.9.8 libswfdec0.3 libsysfs2 libwavpack0
      readline-common wpasupplicant
    The following packages will be upgraded:
      cpp-4.0 gcc-4.0-base gconf2 gij-4.0 grepmap gstreamer0.8-alsa
      gstreamer0.8-audiofile gstreamer0.8-cdparanoia gstreamer0.8-dv
      gstreamer0.8-dvd gstreamer0.8-esd gstreamer0.8-flac gstreamer0.8-gnomevfs
      gstreamer0.8-gsm gstreamer0.8-hermes gstreamer0.8-jpeg gstreamer0.8-misc
      gstreamer0.8-musepack gstreamer0.8-oss gstreamer0.8-plugin-apps
      gstreamer0.8-sdl gstreamer0.8-speex gstreamer0.8-theora gstreamer0.8-tools
      gstreamer0.8-vorbis gstreamer0.8-x klibc-utils libartsc0 libasound2
      libbonobo2-0 libbonobo2-common libcairo2 libcupsys2-gnutls10 libfreetype6
      libgcc1 libgcj6 libgconf2-4 libgcrypt11 libglib2.0-0 libglib2.0-data
      libgnomeui-0 libgnomeui-common libgnomevfs2-0 libgnomevfs2-common
      libgpg-error0 libgstreamer-gconf0.8-0 libgstreamer-plugins0.8-0
      libgstreamer0.8-0 libklibc libogg0 liboil0.3 libopencdk8 libpango1.0-0
      libpango1.0-common libreadline4 libreadline5 libselinux1 libstdc++6
      libtasn1-2 libvorbis0a libvorbisenc2 libxml2 lsb-base module-init-tools
      python2.4-dbus
    65 upgraded, 45 newly installed, 19 to remove and 811 not upgraded.
    Need to get 11.7MB/25.7MB of archives.
    After unpacking 55.6MB disk space will be freed.
    Do you want to continue [Y/n]? y
    Get:1 http://archive.ubuntu.com dapper/main grepmap 1.1.0-1 [19.5kB]
    Get:2 http://archive.ubuntu.com dapper/main klibc-utils 1.1.16-1ubuntu5 [97.3kB]Get:3 http://archive.ubuntu.com dapper/main libklibc 1.1.16-1ubuntu5 [16.4kB]
    Get:4 http://archive.ubuntu.com dapper/universe libreadline4 4.3-18 [104kB]
    Get:5 http://archive.ubuntu.com dapper/main libreadline5 5.1-7build1 [252kB]
    Get:6 http://archive.ubuntu.com dapper/main readline-common 5.1-7build1 [50.2kB]Get:7 http://archive.ubuntu.com dapper/main libssl0.9.8 0.9.8a-7build1 [2591kB]
    Get:8 http://archive.ubuntu.com dapper/main libsysfs2 2.0.0-5build1 [24.9kB]
    Get:9 http://archive.ubuntu.com dapper/main module-init-tools 3.2.2-1ubuntu7 [78.8kB]
    Get:10 http://archive.ubuntu.com dapper/main wpasupplicant 0.4.8-3ubuntu1 [200kB]
    Get:11 http://archive.ubuntu.com dapper/main libsepol1 1.10-1 [94.5kB]
    Get:12 http://archive.ubuntu.com dapper/main libselinux1 1.28-2ubuntu2 [51.0kB]
    Get:13 http://archive.ubuntu.com dapper/main libcupsys2-gnutls10 1.2.0-0ubuntu5 [990B]
    Get:14 http://archive.ubuntu.com dapper/main libcupsys2 1.2.0-0ubuntu5 [119kB]
    Get:15 http://archive.ubuntu.com dapper/main libgutenprint2 5.0.0~rc2-0ubuntu6 [834kB]
    Get:16 http://archive.ubuntu.com dapper/main cupsys-driver-gutenprint 5.0.0~rc2-0ubuntu6 [989kB]
    Get:17 http://archive.ubuntu.com dapper/universe liba52-0.7.4 0.7.4-1 [25.1kB]
    Get:18 http://archive.ubuntu.com dapper/universe libgstreamer0.8-0 0.8.12-1ubuntu1 [679kB]
    Get:19 http://archive.ubuntu.com dapper/universe gstreamer0.8-a52dec 0.8.12-1ubuntu2 [40.4kB]
    Get:20 http://archive.ubuntu.com dapper/universe gstreamer0.8-aa 0.8.12-1ubuntu2 [39.8kB]
    Get:21 http://archive.ubuntu.com dapper/universe libgstreamer-plugins0.8-0 0.8.12-1ubuntu2 [114kB]
    Get:22 http://archive.ubuntu.com dapper/universe gstreamer0.8-alsa 0.8.12-1ubuntu2 [71.2kB]
    Get:23 http://archive.ubuntu.com dapper/main libartsc0 1.5.2-0ubuntu1 [14.8kB]
    Get:24 http://archive.ubuntu.com dapper/universe gstreamer0.8-artsd 0.8.12-1ubuntu2 [37.4kB]
    Get:25 http://archive.ubuntu.com dapper/universe gstreamer0.8-audiofile 0.8.12-1ubuntu2 [43.9kB]
    Get:26 http://archive.ubuntu.com dapper/universe gstreamer0.8-caca 0.8.12-1ubuntu2 [51.2kB]
    Get:27 http://archive.ubuntu.com dapper/main libcdio6 0.76-1ubuntu1 [119kB]
    Get:28 http://archive.ubuntu.com dapper/universe gstreamer0.8-cdio 0.8.12-1ubuntu2 [46.3kB]
    Get:29 http://archive.ubuntu.com dapper/universe gstreamer0.8-cdparanoia 0.8.12-1ubuntu2 [49.5kB]
    Get:30 http://archive.ubuntu.com dapper/universe gstreamer0.8-dv 0.8.12-1ubuntu2 [51.4kB]
    Get:31 http://archive.ubuntu.com dapper/universe gstreamer0.8-dvd 0.8.12-1ubuntu2 [63.0kB]
    Get:32 http://archive.ubuntu.com dapper/universe gstreamer0.8-esd 0.8.12-1ubuntu2 [42.9kB]
    Get:33 http://archive.ubuntu.com dapper/universe gstreamer0.8-festival 0.8.12-1ubuntu2 [37.4kB]
    Get:34 http://archive.ubuntu.com dapper/universe gstreamer0.8-flac 0.8.12-1ubuntu2 [51.3kB]
    Get:35 http://archive.ubuntu.com dapper/universe gstreamer0.8-gnomevfs 0.8.12-1ubuntu2 [50.4kB]
    Get:36 http://archive.ubuntu.com dapper/universe gstreamer0.8-gsm 0.8.12-1ubuntu2 [36.9kB]
    Get:37 http://archive.ubuntu.com dapper/universe gstreamer0.8-gtk 0.8.12-1ubuntu2 [41.9kB]
    Get:38 http://archive.ubuntu.com dapper/universe gstreamer0.8-hermes 0.8.12-1ubuntu2 [38.1kB]
    Get:39 http://archive.ubuntu.com dapper/universe gstreamer0.8-jpeg 0.8.12-1ubuntu2 [49.6kB]
    Get:40 http://archive.ubuntu.com dapper/main libid3tag0 0.15.1b-8 [34.9kB]
    Get:41 http://archive.ubuntu.com dapper/main libmad0 0.15.1b-2.1 [76.9kB]
    Get:42 http://archive.ubuntu.com dapper/universe gstreamer0.8-mad 0.8.12-1ubuntu2 [58.4kB]
    Get:43 http://archive.ubuntu.com dapper/main libmikmod2 3.1.11-a-6ubuntu2 [124kB]
    Get:44 http://archive.ubuntu.com dapper/universe gstreamer0.8-mikmod 0.8.12-1ubuntu2 [40.1kB]
    Get:45 http://archive.ubuntu.com dapper/universe libgstreamer-gconf0.8-0 0.8.12-1ubuntu2 [36.5kB]
    Get:46 http://archive.ubuntu.com dapper/main liboil0.3 0.3.7-0ubuntu5 [113kB]
    Get:47 http://archive.ubuntu.com dapper/universe gstreamer0.8-misc 0.8.12-1ubuntu2 [1252kB]
    Get:48 http://archive.ubuntu.com dapper/universe libwavpack0 4.32-2ubuntu2 [70.7kB]
    Get:49 http://archive.ubuntu.com dapper/universe libmms0 0.2-0ubuntu1 [19.4kB]
    Get:50 http://archive.ubuntu.com dapper/universe gstreamer0.8-mms 0.8.12-1ubuntu2 [38.5kB]
    Get:51 http://archive.ubuntu.com dapper/universe libmpeg2-4 0.4.0b-4ubuntu1 [61.9kB]
    Get:52 http://archive.ubuntu.com dapper/universe gstreamer0.8-mpeg2dec 0.8.12-1ubuntu2 [48.5kB]
    Get:53 http://archive.ubuntu.com dapper/universe gstreamer0.8-musepack 0.8.12-1ubuntu2 [39.8kB]
    Get:54 http://archive.ubuntu.com dapper/universe gstreamer0.8-oss 0.8.12-1ubuntu2 [57.0kB]
    Get:55 http://archive.ubuntu.com dapper/universe gstreamer0.8-tools 0.8.12-1ubuntu1 [140kB]
    Get:56 http://archive.ubuntu.com dapper/universe gstreamer0.8-plugin-apps 0.8.12-1ubuntu2 [35.9kB]
    Get:57 http://archive.ubuntu.com dapper/universe gstreamer0.8-sdl 0.8.12-1ubuntu2 [40.4kB]
    Get:58 http://archive.ubuntu.com dapper/universe libsidplay1 1.36.59-4 [65.9kB]
    Get:59 http://archive.ubuntu.com dapper/universe gstreamer0.8-sid 0.8.12-1ubuntu2 [40.1kB]
    Get:60 http://archive.ubuntu.com dapper/universe gstreamer0.8-speex 0.8.12-1ubuntu2 [49.3kB]
    Get:61 http://archive.ubuntu.com dapper/universe libswfdec0.3 0.3.6-0ubuntu2 [272kB]
    Get:62 http://archive.ubuntu.com dapper/universe gstreamer0.8-swfdec 0.8.12-1ubuntu2 [39.9kB]
    Get:63 http://archive.ubuntu.com dapper/universe gstreamer0.8-theora 0.8.12-1ubuntu2 [48.9kB]
    Get:64 http://archive.ubuntu.com dapper/main libvorbisenc2 1.1.2-0ubuntu2 [82.5kB]
    Get:65 http://archive.ubuntu.com dapper/universe gstreamer0.8-vorbis 0.8.12-1ubuntu2 [54.8kB]
    Get:66 http://archive.ubuntu.com dapper/universe gstreamer0.8-x 0.8.12-1ubuntu2 [89.4kB]
    Get:67 http://archive.ubuntu.com dapper/universe gstreamer0.8-plugins 0.8.12-1ubuntu2 [31.8kB]
    Get:68 http://archive.ubuntu.com dapper/main libatspi1.0-0 1.7.7-0ubuntu3 [197kB]
    Get:69 http://archive.ubuntu.com dapper/main python2.4-dbus 0.60-6ubuntu8 [247kB]
    Get:70 http://archive.ubuntu.com dapper/main libbrlapi1 3.7.2-2ubuntu3 [51.0kB]
    Get:71 http://archive.ubuntu.com dapper/main brltty 3.7.2-2ubuntu3 [739kB]
    Get:72 http://archive.ubuntu.com dapper/main brltty-x11 3.7.2-2ubuntu3 [55.0kB]
    Fetched 11.7MB in 6m56s (28.0kB/s)
    Extracting templates from packages: 100%
    Preconfiguring packages ...
    (Reading database ... 56838 files and directories currently installed.)
    Removing ubuntu-desktop ...
    Removing update-notifier ...
    Removing dbus-1-utils ...
    Removing hal-device-manager ...
    Removing gnome-volume-manager ...
    Removing hwdb-client ...
    Removing hal ...
     * Stopping Hardware abstraction layer:                                  [ ok ]
     * Stopping system message bus...                                        [ ok ]
     * Starting system message bus...                                        [ ok ]
    Removing dbus ...
     * Stopping system message bus...                                        [ ok ]
    Removing ubuntu-minimal ...
    Removing usplash ...
    Removing linux-386 ...
    Removing linux-image-386 ...
    Removing linux-restricted-modules-386 ...
    Removing linux-restricted-modules-2.6.12-9-386 ...
    Removing linux-image-2.6.12-9-386 ...
    
      You are running a kernel (version 2.6.12-9-386) and attempting to remove
      the same version. This is a potentially disastrous action. Not only
      will /boot/vmlinuz-2.6.12-9-386 be removed, making it impossible to boot
      it, (you will have to take action to change your boot loader to boot
      a new kernel), it will also remove all modules under the directory
      /lib/modules/2.6.12-9-386. Just having a copy of the kernel image is not
      enough, you will have to replace the modules too.
    
        I repeat, this is very dangerous. If at all in doubt, answer
        no. If you know exactly what you are doing, and are prepared to
        hose your system, then answer Yes.
    Remove the running kernel image (not recommended) [No]? n
    dpkg: error processing linux-image-2.6.12-9-386 (--remove):
     subprocess pre-removal script returned error exit status 1
    Removing ifrename ...
    dpkg: hotplug: dependency problems, but removing anyway as you request:
     udev depends on hotplug (>= 0.0.20040329-16).
    Removing hotplug ...
    dpkg: initramfs-tools: dependency problems, but removing anyway as you request:
     linux-image-2.6.12-9-386 depends on initramfs-tools (>= 0.17).
    Removing initramfs-tools ...
    Removing udev ...
    Errors were encountered while processing:
     linux-image-2.6.12-9-386
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    pls help
     
  2. QwertyManiac

    QwertyManiac Commander in Chief

    Joined:
    Jul 17, 2005
    Messages:
    6,656
    Likes Received:
    10
    Trophy Points:
    0
    Use the -f command parameter to force it to download all required dependencies

    sudo apt-get -f install xxxxxxxx
     
  3. OP
    OP
    gary4gar

    gary4gar GaurishSharma.com

    Joined:
    May 21, 2005
    Messages:
    4,094
    Likes Received:
    24
    Trophy Points:
    0
    Location:
    Jaipur
    hey now i am not able to boot in.it says initilization of server x failed.no what??

    BTW qwerty:y changed ur avaatar
     
  4. JGuru

    JGuru Well-Known Member

    Joined:
    Dec 25, 2005
    Messages:
    1,705
    Likes Received:
    32
    Trophy Points:
    48
    Location:
    Space-time continuum
    As far as Ubuntu is concerned, if you update the OS it just hangs or doesn't boot!!
    Get the latest release of Ubuntu 6.0
     
  5. OP
    OP
    gary4gar

    gary4gar GaurishSharma.com

    Joined:
    May 21, 2005
    Messages:
    4,094
    Likes Received:
    24
    Trophy Points:
    0
    Location:
    Jaipur

    i requested for cd of ver. 6 in will come in 15-20 days till then pls help me to slve my prob
     
  6. mehulved

    mehulved 18 Till I Die............

    Joined:
    Jul 15, 2004
    Messages:
    5,790
    Likes Received:
    44
    Trophy Points:
    0
    Location:
    India, Mumbai, Marine Lines
    @ JGuru Who said so? I did update the whole distro from breezy to dapper using dist-upgrade. I know others who did it too. We did fine without problems. And it was very easy.
    And he is not doing any upgrades, he's just installing extra packages.
    Solution of his problem lies in his first quote of the first post. But, he's never bothered to read anything so far.
    @gary4gar And did you ever try searching anywhere? The answer to your second post lies here in this forum itself.
     
  7. OP
    OP
    gary4gar

    gary4gar GaurishSharma.com

    Joined:
    May 21, 2005
    Messages:
    4,094
    Likes Received:
    24
    Trophy Points:
    0
    Location:
    Jaipur
    that means i have to first install codes & then any player??
    fot non booting i have to edit cofig file.


    one more thing how to set deafult os from linux to windows 2k in GRUB??
     
Thread Status:
Not open for further replies.

Share This Page