Can't connect my s3 through wifi


Hello guys

This problem that I've been having is a bit complicated one and I hope you guys can help.
Firstly an overview of devices that I have-
Nexus 4
Samsung grand
A micromax phone
IPod touch
A netbook

All my devices are able to connect to wifi except the s3 which I bought about a week ago, for my dad and since then I can't connect it to the WiFi. It gets stuck on obtaining IP address. And strangely, the connection breaks and I can't access the net on my PC too till I switch off the WiFi on my s3.

I tried to connect the s3 to my brothers WiFi connection in his house and it worked liked like a charm. So I searched the net and found only 1 solution, to set my IP as static instead of DHCP in my s3. Oddly enough when I set the IP as static and entered the password, the save option was blackened. I tried to set a static IP for my N4 the same thing happens. I even tried to set static IP when connecting to my brother's WiFi bit I got the same problem.

After that I connected the s3 to my brothers WiFi and downloaded the android update. Surprisingly the s3 can now connect to the WiFi. But now my other phone galaxy grand can't connect to wifi. It gives the same problem that was in s3.

I think there are only a limited number of devices that can connect to a modem. I know it's a bit complicated problem, but I hope I can get a solution.

Ps- all the observation are with only a single device connected to the WiFi.
Pps- my modem is 450tc1 and I have a Mtnl broadband.
Top Bottom