• CONTEST ALERT - Experience the power of DDR5 memory with Kingston Click for details

Bittorrent woes! Help needed!!

Status
Not open for further replies.

ctrl_alt_del

A Year Closer To Heaven
For the last one year, BT had been working like a charm for me. But the speeds suddenly dropped to less than 5kBps in the last one month.

My PC is a PIV 1.5Ghz, 256DDR-RAM with a 256kbps internet connection from our cable service provider, Ortel Telecommunications. They use DOCSIS 2.0 for it. I had been getting a steady download rate of 30kBps with all my torrents. But suddenly one day the torrents started to get cranky. Speeds won't exceed 5kBps. My normal downloads via http links and ftp links still gave me an average of 30kBps, but not so with BT.

However. one thing that struck me odd was that if I tried downloading a small file, say of 5Mb, I would get speed of 30kBps quite easily. But if I put on a bigger file for download, the speeds would drop again, no matter how healthy the torrent be. I was using BitComet at first so tried changing to other couple of clients, but the problem persisted.

Checked my ports status at Shields-Up as well. This is what I got:



However, a friend of mine, who lives in Bhubaneshwar, and is under the same scheme as mine and gets his connection from Ortel, Bhubaneswar has the same port status, on being queried. All his ports show up as blocked. Yet he can download via BT merrily, irrespective of the file sizes.

Now this has left me completely bewildered. Any help or suggestions will be appreciated.
 
I'm using winxp firewall with ports 6881 to 6991 manually configured to be open (under exceptions). No problems whatsoever. Could not try scanning with Shields Up as I'll have to disable my firewall. Currently I'm in the middle of some work and don't want to go offline. Will try that later and post results here.

Possible reasons and solutions -

Your IP is being banned by certain trackers due to low seed ratio. Try setting your proxy (in Azureus) to localhost:4001 and then run JAP (java anonymous proxy, freeware) under anonymizer mode. Also try torrents from trackers that don't have restrictions - check your PM.

Certain clients are banned by some trackers - try G3Torrent, which has a spoofing feature w.r.t. client type.

Your upload bandwidth is choked - use the limit upload feature in your client. Or try Netlimiter v1.3 (will cause problems with Azureus)

Keith
 

siriusb

Cyborg Agent
This could be becasue of a variety of reasons. Off the top of my head, I'll say that your 'number of connections' for a torrent may be limiting the number of seeds/peers you are connected to and hence the reduction in speed.
Another connection limiting factor would be to 'pop' the sp2 tcpip limit if u haven't done so already.

Also, if the health is ok (green in azureus), then no need to check for ports.
 

Deep

Version 2.0
Hi,
It is possible due to port forwarding issue with NAT..try out NetCheck with any torrent i.e. run any torrent and then visit that page..

You can also checkout this page for more info.

Regards,
Deep
 

mail2and

Walking, since 2004.
Same problem here. Hathway does the same thing. All over Mumbai they don't block torrents.. i.e. ports 6681-89.. but the shitty office at Hathway, malad do it. I simply use ports "5000" or "6000" and my torrents work perfectly.
 
OP
ctrl_alt_del

ctrl_alt_del

A Year Closer To Heaven
@Deep: I tried Natcheck. BitComet's listening port was 10641. When I tried it, it showed a success screen. However when I tried using port 6881-6889, I get this:

Fail!
Unable to connect. This likely means you need to adjust your port forwarding configuration, or there is no client running on that port.

@siriusb: I haven't tried it yet, so I just googled it up and see what is to be done. I will do the needful and report back.

@Keith: My ratio was almost 1 when the speeds suddenly slowed down. I generally keep seeding till I achieve a ratio of 1. Anyways. I tried the one you suggested via PM and I got some good speeds as of now. As my happy hours won't kick in until 1AM, I will have to wait till then and see if I get sustained higher speeds.

BitComet is known to be banned by many trackers. So I tried it out with Bitspirit. However the torrents still refused to work while they downloaded with ease on my friends PC.

As for upload, that could be a problem. I know that one should limit the upload a bit to obtain optimum speeds. At first I used a tweak that would limit my upload rates to below 5kBps. But after a fresh installation of XP followed by BC, I noticed that even if I didn't impose any restrictions, I still got higher download speeds. So I left it uncapped. That way my ratio also improved.

Thanks a lot guys. I will have to wait till 1AM to see if it has made any differnce. Thanks for all the help! :)
 

Deep

Version 2.0
I think then the problem could be same as what mentioned by Anand just above your reply...

try changing port in ur software and see what happens...I prefer using Azureus which allows me to change port to xxx number. (I do not know whether this option is there in your software or not)

Regards,
Deep
 
OP
ctrl_alt_del

ctrl_alt_del

A Year Closer To Heaven
For BitComet, you will have to change the Listen Port. I had tried to change it before with no results. It has a random port generator, so I tried it a couple of times. However, I had never tried to check if the generated random port was infact open.
 
OP
ctrl_alt_del

ctrl_alt_del

A Year Closer To Heaven
@siriusb: After reading your previous post, I had googled for more information and had stumbled upon this patch itself. Downloaded the latest version.

However after changing the limit to 50, XP prompts me to put in the WinXP SP2 CD. As advised, when I tried to cancel, the prompt box stops responding. So I force restart. I hope it still manages to get the work done.

As soon its 1 O'Clock, I will post updates on how it has been faring.
 
OP
ctrl_alt_del

ctrl_alt_del

A Year Closer To Heaven
Guys! It seems to be working. Leaving the torrent on for now. Will report back in the morning to see how it turned out! Thanks a lot all!

@siriusb: Managed to set the limit to 50. :) Thanks!
 
Status
Not open for further replies.
Top Bottom