unable to boot from USB after installing windows 10


Broken In
i have windows 10 install in my pc and i want to boot a linux distro with the help of usb i did that before when window 7 was installed in my pc and it worked every time there is option of uefi usb in boot priority as well but now i can't there is only three option in boot priority window boot manager, my hard disk and my dvd drive i tried disabling fast boot and secured boot but nothing seems to be working when i'm trying to boot by pressing f8 key the system after giving a black screen for a second return back to booting windows 10 any help will be appreciated :-o:-o
Update: Problem is resolved now yes one window 10 preview build created some hiccups during installation that's why I changed some USB related functions in bios but after updating my bios and resting it to default; problem resolved now thanks for the response
Last edited:


The Power of x480
Staff member
AFAIK, Windows 10 doesn't mess up the bootloader. You have to check whether your USB drive isn't mess up. Did you erase any files from the bootable USB?
Also, try the usb on another pc or in virtual environment.
Top Bottom