• CONTEST ALERT - Experience the power of DDR5 memory with Kingston Click for details

RJ45 ISP cable works with Laptop, but not with Desktop

anirbandd

Conversation Architect
Hi All,

I have a Spectranet connection which gave us a RJ45 cable directly from the ONT box. That cable is used in a Beetel A7777 WiFi enabled router for providing internet access to all wireless device in our home.

I used an HP Pavilion G6-2303TX Laptop, which used to detect the internet whenever the cable was plugged in the RJ45 socket on the lappy. It has the following communications specs:
Ethernet 10/100 LAN
Bluetooth v4.0
Wireless LAN IEEE 802.11b/g/n

However, when i plug the cable into my Desktop's RJ45 socket, it refuses to identify internet. My motherboard is the following: Motherboards - P8H67-M LE - ASUS

The mobo model on my desktop is pretty old. Is this due to any compatibility issues??
 

RCuber

The Mighty Unkel!!!
Staff member
can you post the network adapter settings of your desktop? set it to auto so that it picks up the IP form DHCP
 

little

Journeyman
Are you plugging the RJ45 cable which came from ONT box directly to laptop or desktop. In this case it may be due to the fact that your laptop's mac address has been registered with Spectranet and your Beetel router has the mac address of your laptop via mac cloning. If this is the case then your laptop and router will work but not your desktop because your desktop has different mac address. For your desktop to work you'll need to connect it to the router(wired or wirelessly) and not directly.

If your laptop and desktop are connected to router via RJ45 cable and only laptop gets internet access then it may be because IPv4 settings on your desktop are not correct. As RCuber said, go to IPv4 properties of your ethernet adapter and set it to "Obtain IP address automatically" so that it can get an IP address from DHCP on your router.

Hope this helps.

- - - Updated - - -

There might be another possibility when you are connecting RJ45 from ISP directly to your desktop. I'm assuming that your ISP doesn't limit your connection to only one registered mac address. In this case you might need to enter correct IPv4 settings in your desktop (just copy the settings from your laptop).
 
OP
anirbandd

anirbandd

Conversation Architect
can you post the network adapter settings of your desktop? set it to auto so that it picks up the IP form DHCP

Are you plugging the RJ45 cable which came from ONT box directly to laptop or desktop. In this case it may be due to the fact that your laptop's mac address has been registered with Spectranet and your Beetel router has the mac address of your laptop via mac cloning. If this is the case then your laptop and router will work but not your desktop because your desktop has different mac address. For your desktop to work you'll need to connect it to the router(wired or wirelessly) and not directly.

If your laptop and desktop are connected to router via RJ45 cable and only laptop gets internet access then it may be because IPv4 settings on your desktop are not correct. As RCuber said, go to IPv4 properties of your ethernet adapter and set it to "Obtain IP address automatically" so that it can get an IP address from DHCP on your router.

Hope this helps.

- - - Updated - - -

There might be another possibility when you are connecting RJ45 from ISP directly to your desktop. I'm assuming that your ISP doesn't limit your connection to only one registered mac address. In this case you might need to enter correct IPv4 settings in your desktop (just copy the settings from your laptop).

i had set my desktop to use some ipv4 address when i was at home. i will clear that setting and set it to auto.

am in office right now. will report back when i reach home.

i should have checked this earlier... thanks for the heads up guys :)

- - - Updated - - -

am home.

it worked.

thanks a lot guys. ya'll are the best :D
 

kg11sgbg

Indian Railways - The Vibrant and Moving INDIA
i had set my desktop to use some ipv4 address when i was at home. i will clear that setting and set it to auto.

am in office right now. will report back when i reach home.

i should have checked this earlier... thanks for the heads up guys :)

- - - Updated - - -

am home.

it worked.

thanks a lot guys. ya'll are the best :D

Pleased + Happy to see that your problems are resolved.:)
 
Top Bottom