Problems installing ubuntu 7.10

Status
Not open for further replies.
Each time i boot with ubuntu live cd it loads the kernel and then shows a black screen.The monitor goes on standby and then some sounds start coming from my cabby.I have no idea abt this prob.THos problem persists with all linux distros.Please help.I doubt that live CD is causing prob afre reading some posts on ubuntuforums thats y m DLing alternate cd so that no graphical probs are there.plzzzzzzzzzz help:(
 

debsuvra

is NOT a PC/Mac
I also think that it is a graphic card related problem. And as u have a 8800 GTS, I think gfx related problems will occur. I know that nVidia released driver support for the latest cards for linux but I think that the usage is still choppy. Urs situation confirms that.

U could try to install with onborad gfx but AFAIK ur MOBO does not have onboard gfx. :(
 
yeah GPU prob si there.I doubt i ll have to install with live cd and then auto update or restricted drivers mite work.
I got fed up and threw all my linux cds,dvds in garbage bin!!!
 
^^
not working.Dont tell me these common solutions as ive tried all!!!!!!!!
plz tell mw any any any method to get my GG working.Its running on vesa drivers.
i DLed the latest drivers but when i enter the command for installign them on GG it gives the error that cant open the particular file!!
plzzzzz help.Even the 100.xx.xx.xx drivers are not working!!
im on GG 64 bit
 

infra_red_dude

Wire muncher!
I think you should've tried 32-bit. Not that it would not haf given probs. But I suspect that to be the culprit. 64bit versions are kinda usually not nice to most!!!!
 
drivers not working even on 32 bit version
when i DL the drivers and enter the command to install it gives the error that cant open that particular file.plzzzzzzzzzzzz help.I think i need to use fedora till then.are the latest nvidia drivers compatible with warewolf(fedora8)?
 

praka123

left this forum longback
Nvidia 8xxx series in Ubuntu Gutsy 7.10

@sunny: 64-bit will work.
But you need to have some patience :p

first of all,there is no scope in installing Ubuntu's nvidia driver as the version is old.
install Ubuntu 7.10 with ur graphics cards removed(nvidia).after installation,edit
ur /etc/X11/xorg.conf and go to section "device" and choose driver as "vesa" save.
edit: Here,after installation without graphics card finishes,
u should install gfx cards after shutdown the system.
when u reboot,u'll get a X error(in a blue console).now u press CTRL+ALT+F1 and login with your username and passwd.there u can use a editor called "nano" which is easy.

you can edit using nano as follows
Code:
sudo nano -w /etc/X11/xorg.conf
edit section "device" for driver vesa and save.

If no xorg.conf is generated,you should make one using :
Code:
sudo dpkg-reconfigure xserver-xorg
^selecting "vesa" as driver.



shutdown the system.install ur graphics cards back.now u can get Gnome in vesa mode.

try to follow:
get the latest nvidia 64-bit driver from nvidia website:

http://www.nvidia.com/object/linux_display_amd64_169.09.html

Linux x64 (AMD64/EM64T) Display Driver

Version: 169.09
Operating System: Linux x64 (AMD64/EM64T)
Release Date: January 21, 2008

Release Highlights
  • Fixed a problem causing the fan on some GPUs to always run at full speed.
  • Fixed a bug that caused the X driver to crash if the X.Org GLX extension module was loaded intead of NVIDIA’s.
  • Improved the X driver’s awareness of the current notebook docking status.
  • Fixed brightness control on HP Compaq notebooks.
  • Fixed a bug in the Linux/i2c algorithm driver implementation that prevented core transfer types from succeeding.
To download and install the drivers, follow the steps below:
STEP 1: Review the NVIDIA Software License.
You will need to accept this license prior to downloading any files.
STEP 2: Download the Driver File
Download - NVIDIA-Linux-x86_64-169.09-pkg2.run

STEP 3: Install
Type "sh NVIDIA-Linux-x86_64-169.09-pkg2.run" to install the driver. NVIDIA now provides a utility to assist you with configuration of your X config file. Please see Chapter 3 of the README or run 'man nvidia-xconfig' for details on usage. Instructions for those wishing to edit their X config file by hand can also be found in the README.
now,open a terminal in Gnome(Applications>Accsrs>terminal)
run:
go to the folder where u have downloaded nvidia driver(most probably to Desktop if u use firefox to download,u can in a terminal use "cd" command to change directory to where ur driver is located.for eg: cd Desktop will open ur ~/Desktop) then,
make sure the driver is executable by:
Code:
sudo chmod 755 NVIDIA-Linux-x86_64-169.09-pkg2.run

If u still fails to get the terminal opened in the directory where u downloaded nvidia driver, open Nautilus(in menu Places>Home Folder).
now locate ur driver either in home folder or on Desktop and make sure the PATH.now open terminal and use "cd" to move to where the download is located/
now run:

Code:
sudo  sh NVIDIA-Linux-x86_64-169.09-pkg2.run
^follow the guidelines and complete the installation.
now,after completing the installation,use the nvidia-xconfig utility to make a xorg.conf file for u(warning:the file generated will be in ur /root dir by default).
OR
open a terminal and run
Code:
sudo dpkg-reconfigure xserver-xorg
^and select "nvidia" as ur driver.

restart ur display or ur system to make sure this driver is working.
follow the guide if u get confused:
http://us.download.nvidia.com/XFree86/Linux-x86_64/169.09/README/


below is my /etc/X11/xorg.conf for reference especially regarding the section "device":
Code:
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
        Fontpath        "/usr/share/fonts/X11/misc"
        Fontpath        "/usr/share/fonts/X11/cyrillic"
        Fontpath        "/usr/share/fonts/X11/100dpi/:unscaled"
        Fontpath        "/usr/share/fonts/X11/75dpi/:unscaled"
        Fontpath        "/usr/share/fonts/X11/Type1"
        Fontpath        "/usr/share/fonts/X11/100dpi"
        Fontpath        "/usr/share/fonts/X11/75dpi"
        # path to defoma fonts
        Fontpath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
        Load            "dbe"
        Load            "glx"
        Load            "ddc"
        Load            "extmod"
        Load            "type1"
        Load            "freetype"
        Load            "bitmap"
        Load            "int10"
        Load            "vbe"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc104"
        Option          "XkbLayout"     "us"
        Option          "XkbOptions"    "lv3:ralt_switch"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"        "/dev/input/mice"
        Option          "Protocol"      "ImPS/2"
        Option          "ZAxisMapping"  "4 5"
        Option          "Emulate3Buttons"       "true"
EndSection

Section "Extensions"
    Option "Composite" "Enable"
EndSection

[U][B]Section "Device"
        Identifier      "nVidia Corporation G70 [GeForce 7300 GT]"
        Driver          "nvidia"
        Busid           "PCI:1:0:0"
        Option          "AddARGBVisuals"        "True"
        Option          "AddARGBGLXVisuals"     "True"
        Option          "NoLogo"        "True"
        Option          "UseEdidDpi"   "FALSE"
        Option          "DPI"   "96 x 96"
EndSection
[/B][/U]
Section "Monitor"
        Identifier      "S/T 57/56E/V"
        Option          "DPMS"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "nVidia Corporation G70 [GeForce 7300 GT]"
        Monitor         "S/T 57/56E/V"
        Defaultdepth    24
        SubSection "Display"
                Modes   "800x600"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        screen          "Default Screen"
        Inputdevice     "Generic Keyboard"
        Inputdevice     "Configured

try boy!

Hoping you are on 64-bit
Ubuntu
 
Last edited:

praka123

left this forum longback
^@sunny: try to understand.are u not even ready to try :?
I have Just finished using nvidia script to install onto my new ubuntu install.

Here is the deal:
I know that u have no onboard gfx.thats why I am asking u to complete the installation with ur nvidia gfx cards removed.
after completing the installation,shutdown the system and re-insert ur both cards.
then boot Ubuntu.when Ubuntu errors with no card found or some other X error message,press alt+f1 and login with ur username and password.

then configure ur internet connection and remove the "#" before the repos in /etc/apt/sources.list ,then do a sudo apt-get update.afterwards ,
Code:
sudo apt-get install build-essential linux-headers-`uname -r` nvidia-kernel-source nvidia-kernel-common
now go to the dir where u downloaded nvidia script.
or
if u have not downloaded,with internet connection ON,
Code:
wget -c fftp://download.nvidia.com/XFree86/Linux-x86_64/171.05/NVIDIA-Linux-x86_64-[B]171.05[/B]-pkg0.run

now after downloading,make it executable,
Code:
sudo chmod +x NVIDIA-Linux-x86_64-171.05-pkg2.run
now run,
Code:
[B]./[/B]NVIDIA-Linux-x86_64-171.05-pkg2.run
select with ALT,TAB to accept,then follow the installer until it completes.

I can 100% gurantee that this method works.but you are searching for other distros :lol:

after completing the installation,you have to make a xorg.conf file.
do :
Code:
sudo dpkg-reconfigure xserver-xorg
^select "nvidia" and go!in CLI installer u can use ALT,TAB,ENTER(return) keys to select items.

you should refer my earlier posts regarding /etc/X11/xorg.conf and /etc/apt/sources.list

Best of Lux.

If u lacks the patience,show this guide to any LUG members near to you or even a windows guy he can do it for you.

Also,editing in text mode(CLI),u can use a nice editor called nano which is n00b friendly

u can invoke as below:
Code:
sudo nano -w /etc/apt/sources.list

and after removing "#" infront of repositories,u should press CTRL+O and answer "yes" to save.then press CTRL+X to exit.
also refer my xorg.conf :)

dont panic,every time u see that text interface.In order to complete the installation,you have to remove both of ur cards in SLI mode.OK?
then after completing ubuntu installation,shutdown the system,re-insert both the cards,and follow what is wrote above.

I believe I have explained my best.
@qwerty,mehulved:Help him :?

and..Fedora is gonna make it tough for u :-|!
Infact many Ubuntu users with 8800ultra in SLI +twinview works fine for them;why NOT you?
 

praka123

left this forum longback
^and I have given the instructions and latest nvidia-171.05 driver for 64-bit Ubuntu!be sure on that :p

and I have finished the installation with nvidia script,it installs nvidia-xconfig,nvidia-settings(the configuration GUI) all in correct directories in Ubuntu. :p
 
Status
Not open for further replies.
Top Bottom