Not able to get display after installing new GFX card helppppppppppppp

bkpeerless

In the zone
I just bought 1060 graphics card from EVGA. As this card dont support vga. I bought new hdmi cable. now when i installed it . Every thing was fine but after driver got installed and machine restarted , i am not getting display any more. Sometime display comes but till windows is loading then again no signal. mob is gigabyte b75 with latest bios.

Why is it happening.

i am using dell 2240l monitor with hdmi.
I feel the resolution is not supported that gfx card is sending.

- - - Updated - - -

oh i can hear window loading and shutting down using allt f4 n all
 

Hiesenberg

Broken In
Seems like a driver compatibility issue. As you said, no video o/p after installing new driver.

Try to log into system using safe mode and uninstall / roll-back the GPU driver.

Or try to get the video o/p directly from Motherboard, if it has the connection for video
 
A

amit.tiger12

Guest
Is it necessary while installing GPU (or 1st time computer installation) that first setup all things using motherboard video connection??
 

Hrishi

******************
Is it necessary while installing GPU (or 1st time computer installation) that first setup all things using motherboard video connection??
Nope. In fact some setups don't even had iGPU and need a discrete class GPU for video output.

I would suggest you to connect the display on motherboard's VGA/HDMI port and then boot into BIOS. Disable GPU from there.
Boot to windows and clean un-install the nVidia driver.
Download a stable but older and different release of the driver.
Reboot, enable the video card, boot again and this time connect through 1060's hdmi port.
Install the drivers and see if this works.

Sent from my ONE E1003 using Tapatalk
 
OP
bkpeerless

bkpeerless

In the zone
I changed from hdmi to hdmi to dvi to hdmi . a friend said dell 2240l dont support newer hdmi only very old hdmi. He said to change n get dvi to hdmi . Hope it works. if that also fails will get hdmi to vga converter :(


^^^i will also follow the steps u told
 

whitestar_999

Super Moderator
Staff member
a friend said dell 2240l dont support newer hdmi only very old hdmi
|
a friend said hyundai elite e20 is not compatible with old neighbourhood petrol pump as it is the latest model with latest engine.

HDMI :: Manufacturer :: HDMI 2.0 :: FAQ for HDMI 2.0
Is HDMI 2.0 backwards compatible with HDMI 1.x?
Yes, all HDMI versions are fully backward compatible with all previous versions.

Instead of listening to "friends/shopkeepers" always do some research first.The first thing I would have asked is which version of windows is installed on the system & if answer is win 10(any version) then i would have suggested to try with win 7/8.1.
 
OP
bkpeerless

bkpeerless

In the zone
what is your PC specs, same as in your signature?

yes
7770 Is dead driver also uninstalled long time ago.

- - - Updated - - -

I did good research but no solution. In digit also no solution. :( don't anyone have dell 2240 l with hdmi connection.

My friend had same monitor he was using dvi to hdmi. so I listened. win 7 is my os

- - - Updated - - -

ohh I was also getting message on dell resolution not supported plz switch to 1900 * 1800 60 hz (1080 resolution )
 

whitestar_999

Super Moderator
Staff member
Try different drivers starting from the latest one from nvidia site.Another sure way to check is by testing card in another pc.
 

bssunilreddy

Chosen of the Omnissiah
I am running Dell ST2220L with HDMI 2.0 using GTX950 and there is no issues at all.
I have Win 10 as my OS.

Sent from my ASUS_T00K using Tapatalk
 

Desmond

Destroy Erase Improve
Staff member
Admin
Also tell which power supply you are using. Chances are that the GPU is unable to draw enough power.
 

topgear

Super Moderator
Staff member
I think the graphic driver is unable to detect the monitor correctly so it's setting some abnormal resolution / refresh rate and that's why display is not coming.
 

Desmond

Destroy Erase Improve
Staff member
Admin
In that case rebooting into safe mode should solve the problem.

Sent from my A0001 using Tapatalk
 

topgear

Super Moderator
Staff member
Yes,

1. rebooting into safe mode and setting the resolution there
2. boot into VGA mode or low resolution mode and set the correct resolution from there may also work
3. Op can also try disabling the onboard display adapter from Device Manager ( Under Display Adapters )
 

anirbandd

Conversation Architect
so you got it to work via DVI-HDMI converter?

What about the native HDMI output? Does that still not work?
 
OP
bkpeerless

bkpeerless

In the zone
Nope there is vast improvement in pic quality. my 7770 use to run by dvi -i to vga converter. this is the first time i m running the monitor with digital signal and things are beautiful.
The problem was when i was using hdmi to hdmi after installing driver it was taking a resolution way above. its support by monitor thats why message use to come need resolution 1900*1080 at 60
in this wire after installing driver n restarting the default resolution it took was that .
thats my thought though.
 
Top Bottom