Need help with youtube videos!!

pkanhe

Broken In
Whenever I try to play youtube videos on my computer, they are never smooth and always lag. The same videos play fine when I download and watch them. I also have a fast (very fast) internet connection. Could anyone suggest the solution to this??

My pc specs are -

HP Pavillion tx1000
Windows 7 Ultimate 32-bit
AMD Turion 64 X2 TL-56
4 GB RAM
NVIDIA GeForce Go 6150
 
> Which browser?
> Did you update the browser and Flash player?
> Do videos stream smoothly on other sites?
> What is you Internet speed?
 

TheHumanBot

Padawan
^1 google sites works awesomely on chrome.
personal exp. tried to translate a page in firefox and it won't work but in chrome it automatically asked me to translate page and worked :lol:
 

Vyom

The Power of x480
Staff member
Admin
Whenever I try to play youtube videos on my computer, they are never smooth and always lag. The same videos play fine when I download and watch them. I also have a fast (very fast) internet connection. Could anyone suggest the solution to this??

"Very fast" internet connection is not enough information.
What is the exact speed? Do a SpeedTest on speedtest.net and share the results.

Youtube have been sucky lately. Algorithms designed to automatically adapt to the bandwidth available. On a PC with less than 1 (about) Mbps that means video will can start with 240p then as Youtube finds out it has more bandwidth it will increase the quality to 480p, and then automatically get stuck when the buffer runs out.

Thats why when I was on 512kbps I had no way to watch a YT video smoothly without downloading. Now I upgraded to 1 Mbps and atleast it runs a bit smooth now.
 

flyingcow

Shibe
iirc if you are running chrome there are two flashplayers in the plugins tab, disable the peppermint one and you are good to go
 
OP
P

pkanhe

Broken In
I use chrome which does not allow me to update flash player manually. Videos are almost always laggy on youtube, but are better on other sites. Attached is a screenshot of my speedtest.net test. Untitled.jpg
 

Vyom

The Power of x480
Staff member
Admin
Sigh.. So even 14 Mbps is not fast enough for YouTube. :|

Try different browser like Firefox. I don't know why downloading videos would take time on a 14 Mbps connection. Are you downloading in 1080p? Try to download the lower quality one. 480p is enough to watch most videos!
 
OP
P

pkanhe

Broken In
Sigh.. So even 14 Mbps is not fast enough for YouTube. :|

Try different browser like Firefox. I don't know why downloading videos would take time on a 14 Mbps connection. Are you downloading in 1080p? Try to download the lower quality one. 480p is enough to watch most videos!

Thats the whole issue.. i dont want to download videos but watch them on youtube
 

flyingcow

Shibe
did you try the method i posted earlier??
ill mention it again-
go to chrome://plugins/ (put it in your url BAR)
probably the first plugin on the list will be "Adobe Flash Player (2 files)" if not scroll below and click "+details" on the top right...
now you will see 2 files, disable the one with the location, which says pepperflash
ex- C:\Users\admin\AppData\Local\Google\Chrome\Application\30.0.1599.101\PepperFlash\pepflashplayer.dll
^^disable this one,

if still doesnt work enable it and disable the other one....it has worked for me a several times
:)
 
OP
P

pkanhe

Broken In
did you try the method i posted earlier??
ill mention it again-
go to chrome://plugins/ (put it in your url BAR)
probably the first plugin on the list will be "Adobe Flash Player (2 files)" if not scroll below and click "+details" on the top right...
now you will see 2 files, disable the one with the location, which says pepperflash
ex- C:\Users\admin\AppData\Local\Google\Chrome\Application\30.0.1599.101\PepperFlash\pepflashplayer.dll
^^disable this one,

if still doesnt work enable it and disable the other one....it has worked for me a several times
:)

Will try that today
 
Top Bottom