Need help with Weird frequent Disconnections


I have a PPPoE connection from a local ISP (MAC binded from the ISP) over TP-Link W8968 which was working fine till now, but from a past few days there have been constant disruptions in the internet connectivity. PPPoE connection status shows Link Up, but internet becomes unreachable, shows Server not Found for any new sites open. Weird things happen like if Facebook is open and internet starts acting up, Facebook would work fine if you click the Home button in your Wall, but if you hard refresh the page (Ctrl+f5), it directs to Server not Found page. Same thing with google, google search will work fine, but no new links would open and hard refreshing it would result in Server not Found. It starts working in 2-3 mins and then stops randomly after couple of mins.

DNS is unreachable in the meantime, so i tried doing tracert to facebook's ip when it showed server not found. Tracert completed without any hiccups, but i wasn't able to access or it's IP from the browser, started working after about 30 secs.

I tried setting up the PPPoE connection directly without the router on my laptop, it works on the laptop, but if i create an ad-hoc network from it and connect other devices to it, same thing happens with those devices as well, frequent disconnections, though internet works fine in the laptop with direct connection. Both wired and wireless devices are affected from either router or the ad-hoc server laptop. That is, if one device gets Server not found on a website, that website won't work on any of the device connected apart from the ad hoc server.

ISP says nothing wrong at his side, tried clearing the DNS cache and renewing the IP, resetting the router, nothing worked. Any solutions?

Update: Seemingly forcing Google DNS on any connected node resolves the issue, is there any settings for PPPoE connection in W8968 to force Google DNS? Or it has to be done independently on each connected device?
Last edited:
Top Bottom