Help! XP doesn't boot

Discussion in 'Software Q&A' started by milganz, Dec 28, 2004.

Thread Status:
Not open for further replies.
  1. milganz

    milganz New Member

    Joined:
    Dec 5, 2004
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    New Delhi
    I recently installed SuSE Linux 9.1 on my machine. I installed it on three new partitions: /boot, / and swap. I installed GRUB on the /boot partition. But now when I start the PC, when it comes to booting, it says "Missing Operating System". What can be the problem? Please help me!!
     
  2. naveenchandran

    naveenchandran New Member

    Joined:
    May 16, 2004
    Messages:
    451
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    ** Hosur ** Operating System:GNU
    I think by using SuSE 9.1 YaST You will not face any problem but............

    Better try reinstalling SuSE.
     
  3. theraven

    theraven Active Member

    Joined:
    May 5, 2004
    Messages:
    2,912
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    off to "never ever" land
    u DO mean winxp isnt booting right ?
    or suse ??
    ur topic and post are totally confusin
    anyways if its xp that doesnt boot
    then use the bootable install cd
    enter recovery mode
    and type in fixboot and fixmbr
     
  4. Tech&ME

    Tech&ME Banned

    Joined:
    Oct 5, 2004
    Messages:
    1,438
    Likes Received:
    5
    Trophy Points:
    0
    Location:
    Bangalore
    Well! ya if you mean XP is not booting, you are right XP will not boot b'coz SuSe Linux 9.1 has damaged or say overwritten the MBR with its own. If the MBR is badly written you cannot recover it. Here is the solution.

    Method I:
    If you have an installation CD of Windows XP boot from this CD and go t the recovery concole and type 'fixmbr' this should work. if not try method II

    Method II:
    In case you cannot boot from the CD to the recovery console. Remove your hard disk fromm your computer, install it in your friends computer as a slave drive and then make necessary changes. Change the boot.ini file if it contains extra lines, etc. Reconnet the drive to your PC if it works its your luck. If not use method III.

    Method III:
    Again reconnet the drive to your friends PC and if by luck your PC hardware configuration and that of your friends is exactly the same you can be lucky here. All you have to do is remove the boot.ini file, ntdlr, ntdetech.com from the root partition of your drive where your OS is installed(back this up instead of deleting it) , now go to your friends OS and change the boot.ini file to boot into your OS. For example: add this line if your friend is running windows XP on his c:\ and your OS is in the first partition of the slave drive. under the head [operating system]

    multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect
    Reboot, u will see an option to boot into your OS, select it, it should work.
     
  5. technoteen

    technoteen New Member

    Joined:
    Oct 9, 2004
    Messages:
    149
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Nagpur
    please canyou be more clear about your question??

    does it gives that message on booting into windows xp?
    is your windowsxp installation alright, that you have not accidentally installed suse on it ?
    or its that the only mesage you get ,that is, you are not even able to boot into suse?

    i will say dont copy any files from others comp

    Considering that you are stuck in third problem
    first of all boot using your suse cd and reinstall grub using the recover mode

    if you dont mind loosing your suse installation use the fixmbr option of windows and reinstall suse again

    and if you are stuck in second problem, then only God save you
     
  6. chetan

    chetan New Member

    Joined:
    Nov 25, 2004
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    amreli
    hi after installing linux ya it may be possible it damage your xp an the first try by tech&me technique fut it may give some error after words u try it repair or reinstall
     
  7. OP
    OP
    milganz

    milganz New Member

    Joined:
    Dec 5, 2004
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    New Delhi
    More details of my problem

    Sorry I wasn't more specific when making my post.

    As I said, I installed SuSE on three new logical partitions on the extended partition, making them '/boot', 'swap' and '/' respectively. I made it a point to install bootloader GRUB on '/boot' partition instead of the MBR, and the option saying "Leave MBR code untouched" was selected.

    Now, once SuSE is installed, whenever I start up my computer, and it comes to booting into an OS, a message is shown: "Missing Operating System", and this is the only thing that appears on my screen. So I can't boot into anything.

    I checked my BOOT.ini file using a bootable disk (as all data is intact), and it's like this:

    [boot loader]
    timeout=10
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

    I had earlier installed RedHat Linux 9 on the same machine, and the machine used to work perfectly (again I installed nothing on the MBR, but on '/boot').

    NOW can anyone help me?

    Thanks.
     
  8. technoteen

    technoteen New Member

    Joined:
    Oct 9, 2004
    Messages:
    149
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Nagpur
    there is the problem

    you had installed redhat on it earlier and redhat writes the mbr

    so you will have to write the mbr again, for doing so use the windows xp bootable cd to boot into recovery mode and use fixmbr command
     
  9. Tech&ME

    Tech&ME Banned

    Joined:
    Oct 5, 2004
    Messages:
    1,438
    Likes Received:
    5
    Trophy Points:
    0
    Location:
    Bangalore
    It seems however the MBR has been corrupted, u can repair the MBR using the instalation CD of WinXP as I said earlier, boot from the installation CD and go to the recovery console and type 'fixmbr' to fix the mbr. But since the error you are getting is 'missing operating system' that usually means a .dll file or system files in your windows\system32 folder is either missing of corrupted which is required to start the OS. It is very difficult to determine which .dll is corrupted, I will suggest you to check the file size of the .dlls to check if they are ok or not. If not copy new files to replace the old ones. Btw. your boot.ini file is also not correct the timeout should be 30 instead of 10, it indicates the boot.ini file has also been modified by Linux. try to fix this by using fixboot command. If nothing works I suggest you to re-install windows XP.
     
  10. Tech&ME

    Tech&ME Banned

    Joined:
    Oct 5, 2004
    Messages:
    1,438
    Likes Received:
    5
    Trophy Points:
    0
    Location:
    Bangalore
    Hey ! Did you resized your primary partition using Linux to make room for the Linux installation ?? If yes, the files are missing in the primary partition , Linux deleted them or overwritten on them, this is a know issue if you make partitions using Linux (re-size and then partition them). If this is the case, i will suggest u not to solve this problem by doing this and that but simply re-install winXP. Btw. check your harddisk in the BIOS, it should be in LBA Mode.
     
  11. swatkat

    swatkat Active Member

    Joined:
    Mar 12, 2004
    Messages:
    2,060
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    Shimoga/ಶಿವಮೊಗ್ಗ
    How many drives do u have in Windows?
    Tor Rebuild the Boot.ini use can use the following method:-
    Boot from XP CD and choose Repair option.Then in Console type the following commands:-

    Attrib -H -R -S C:\Boot.ini
    DEL C:\Boot.ini
    BootCfg /Rebuild
    Fixboot
     
  12. swatkat

    swatkat Active Member

    Joined:
    Mar 12, 2004
    Messages:
    2,060
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    Shimoga/ಶಿವಮೊಗ್ಗ
    The problem may be due to the fact the a wrong partition is SET as ACTIVE partition.
    So boot from Floppy and then type fdisk and press Enter.
    Then there choose Y to support Large Hard Disks.
    Then in next screen,choose choice 2 and press enter.
    Then type the partition number in which XP is installed to make it Active partition and press Enter and the press ESC to Quit.
     
Thread Status:
Not open for further replies.

Share This Page