• CONTEST ALERT - Experience the power of DDR5 memory with Kingston Click for details

GMA880-E45 issue or just bad luck?


I had 5 hard drives, 400GB, 500GB and 2TB (all Seagate) and 640GB and 1TB (both WD). I tried to using them through dock but on both of my systems, the laptop and the desktop it is now detecting dock as "Initio controller" whilst earlier it was working fine. So assuming that dock might be at fault I tried to use the disks directly in the system through SATA ports but even then it didn't show up neither in BIOS nor in Windows upon booting. Tried if Linux detects them but no success there either. Config is AMD Athlon X2 @ 3GHz, 4GB DDR3 1333MHz, MSI 880GMA-E45, ATI HD5570
WTF is wrong with this system? The Seagate 400GB blew its controller board when I connected it to the X-Dock in the cabinet (CM690 II Advance). I mean this is my first AMD rig and it has proved to be a complete P.I.T.A till now.
Even now it is giving BSOD after updating Win 7 to SP1. When I tried to reformat, I'm getting error that CD/DVD drive was not able to communicate to the device connected/ u want to install location.
In short, is my motherboard screwed?
This is the error I get now, I had to type it all here

Windows has encountered a problem communicating with a device connected to your computer.
This error can be caused by unplugging a removable storage device such as an external USB drive while the device is in use, or by faulty hardware such as a hard drive or CD-ROM drive that is failing. Make sure any removable storage is properly connected and then restart your computer.
If you continue to receive this error message, contact the hardware manufacturer.
Status: 0xc00000e9
Info: An unexpected I/O error has occurred.

Other sick thing is that when in BIOS I put On-Chip ATA devices in AHCI mode, it shows IDE Primary Master and Slave as Not Detected and if I shift it to IDE then again it shows both Not Detected and SATA 1 to 6 also as Not Detected !
BUT when I go to Boot Sequence selection, it lists just my 2 DVD drives and the 160GB HDD and all 3 as IDE devices.
The motherboard has been flashed to the latest version.
Problem with Sunbeam dock is that earlier it was working fine but now it is being detected as "Default Initio controller" by both laptop and desktop so now whatever HDD I place in dock, it is not being detected, let alone read.
After resetting the BIOS by manually taking out the CMOS cell, now BIOS shows the 2 DVD drives and the 160GB HDD under SATA devices but it is still not detecting the 1TB WD HDD. These 2 issues are driving me mad as all of my data is in these HDD and I'm unable to access them both via dock and via hard-jacking 'em in.
I tried doing all the fixes for Initio controller like deleting infcache file in System32/drivers folder and all but still no luck. I tried using these drives on my friend's PC also and there also they are not being detected. Is RMA the only possible solution? New problem now is that even after a clean fresh re-install the Windows hangs after 2 minutes of startup and after 5-10 minutes gives BSOD. Should I RMA the motherboard also?
Top Bottom