• CONTEST ALERT - Experience the power of DDR5 memory with Kingston Click for details

BSNL Router configuration

Cool Buddy

Wise Old Owl
I recently got a BSNL wi-fi Router (model ITI DNA A211-I). I got it second hand from someone who got his connection disconnected. It had been working fine for him, I had checked this.
Now as it happened, the day I got the router home, there was some problem in the telephone line and I wasn't aware of this. So when I connected the router, the DSL light was on but Internet wouldn't get connected. I thought this was happening because the router was being used in Bangalore and I am in Kolkata. So I reset the router using the reset button on the back. Later I found out that the problem was with the connection when I used my old modem.
So, then I configured the router with my username password, but it doesn't connect on its own. I selected the connection type as PPPoE from the router interface, still I need to dial the connection from the PC. This means I can't use it with 2 devices simultaneously or with a device that is incapable of dialing (like a phone).
I looked up many forums and the BSNL website and I configured exactly as they have told. But it still doesn't work. I still need to dial the connection to get connected. Any idea how to fix this?
 

sygeek

Technomancer
First of all please reset the router. After that, all you need is to configure the adsl router with your username and password.

Please tell us what steps you took to configure the router.
 
OP
Cool Buddy

Cool Buddy

Wise Old Owl
^^ Already did that a couple of times

Here are a few screenshots of the router configuration

clip1d.jpg


clip2l.jpg


clip3m.jpg

In the above step, I have also tried with PPP debug mode disabled.

clip4x.jpg

In the above step, I have also tried with IGMP multicast disabled, the connection still needs to be dialled.

clip5z.jpg


clip6d.jpg


In Routing I have checked Enable Automatic Assigned Default Gateway
In DNS I have checked Enable Automatic Assigned DNS
IPV6 Enabled is unchecked inside IPV6
In Port Mapping, Enable virtual ports is unchecked

The above four settings are default, I haven't changed anything
 

ico

Super Moderator
Staff member
Uncheck "Dial on demand" in screenshot #2 and IGMP Multicast in screenshot #4.

Also disable PPP Debug mode. No use of keeping it enabled.
 

ico

Super Moderator
Staff member
How did you use to connect earlier when you had your own modem?

Dial through the computer i.e. Bridged mode?
 
OP
Cool Buddy

Cool Buddy

Wise Old Owl
Yes I used it in bridged mode. Does that make any difference?
I don't think that my old modem would affect anything, cuz everything is supposed to happen inside the router
 

sygeek

Technomancer
Below steps are numbered according to each screenshot you posted.

Follow everything as mentioned, even if you have tried this, repeat it over again:
  1. Everything's fine, leave as it is.
  2. Everything's fine, leave as it is.
  3. Disable Dial On Demand and change MTU Size to 1942.
  4. Change Service name to "pppoe_0_35_1".
  5. Everything's fine, leave as it is.
  6. Enable "IGMP Snooping" and change "Standard mode" to "Blocked mode".
Some questions: As ico said, did this adsl router work in bridged mode? Does the old modem work with the line at the moment? Is the internet LED ON with this router? Also, is the DSL LED blinking?

Just to make sure, you aren't using the wi-fi router as an extension to the old modem, are you?
 
Last edited:
OP
Cool Buddy

Cool Buddy

Wise Old Owl
[/quote]
Below steps are numbered according to each screenshot you posted.

Follow everything as mentioned, even if you have tried this, repeat it over again:
  1. Everything's fine, leave as it is.
  2. Everything's fine, leave as it is.
  3. Disable Dial On Demand and change MTU Size to 1942.

There is no setting named MTU Size

  1. Change Service name to "pppoe_0_35_1".
  2. Everything's fine, leave as it is.
  3. Enable "IGMP Snooping" and change "Standard mode" to "Blocked mode".
Some questions: As ico said, did this adsl router work in bridged mode?
No, earlier owner used it in PPPoE mode and it worked perfectly

Does the old modem work with the line at the moment?
Yes, there was no problem with my old modem, I got this one for Wi-Fi

Is the internet LED ON with this router?
No

Also, is the DSL LED blinking?
No, it is stable. Internet works fine after I dial the connection

Just to make sure, you aren't using the wi-fi router as an extension to the old modem, are you?

Old modem is disconnected and it is nowhere near the PC

I will try the rest of the changes suggested by you and reply again
---------------------------------

Tried all that, Didn't help, still need to dial the connection from the PC
 
Last edited:

ico

Super Moderator
Staff member
If you used Bridged mode, then change your LAN settings. Now you need to set everything to 'automatically" obtain IP.

automatic-ip-configuration-windows-7.jpg


I guess this isn't done.
 

thefirstgod

Right off the assembly line
Re: BSNL Router configuration [Changing the Downstream rate]

hi,

i need to change the downstream rate which atm is 342kbps. it should be 1024kbps as per the broadband plan that i am using.

is there a way that i can change this setting in my modem or do i have lodge a complaint to the isp provider?

thanks
 
Top Bottom