auto log out

subhad43

Right off the assembly line
Hi, I am using an tp-link TLWR740N wireless 150 mbps N router, I got a net connection from pmpl(meghbela) broadband over static IP and I have to authenticate via their web portal.

I have set up the static IP, DNS, Gateway,Subnet Mask on my router, and also successfully set the connection. Now, I can connect the mobile devices by connecting to the WiFi, Opening pmpl's web portal and log in, Minimize the tab and Work in other tab.


But, the problem is, After sometimes the net connection gets disconnected,(but the wifi Signal still remains), I have to again log in that Web portal(From mobile or laptop) and again give user name and password.This is happening every half an hour. This has been a serious problem for me. Can anybody give a solution? thanks in advance
 

Vyom

The Power of x480
Staff member
Admin
Your internet provider requires you to login to authenticate, as you already know. But once connected it seems you have a session timeout of 30 min. Means if you don't use broadband for 30 min, then it automatically logs you out.

I myself face this problem since I have TP Link TL-MR3420. Solution came out only to flash a custom firmware and write a custom script for the same.
I discussed this problem in this thread, you might want to look at it: http://www.digit.in/forum/networkin...ngle-support-budget-2-2-5k-2.html#post2123744

I still have to work on the script though.
 

whitestar_999

Super Moderator
Staff member
i know about your issue & just like you said a custom firmware+script is the only solution.since op mentioned disconnection while working on the mobile/laptop i suggested this solution.
 
OP
S

subhad43

Right off the assembly line
if I put a download in the background even a torrent download, the connection gets lost every half an hour.
 

Vyom

The Power of x480
Staff member
Admin
if I put a download in the background even a torrent download, the connection gets lost every half an hour.

Then I am sure its some problem from ISP's end. Nothing from your side.
Try KeepAlive and post your results.
 
OP
S

subhad43

Right off the assembly line
I increased the address lease time , changed the dns address to my dns address that was assigned during my connection and it has worked for me. Now i can stay connected to the internet for about 46 hours uninterruptedly
 

sbhadra_se

Broken In
I increased the address lease time , changed the dns address to my dns address that was assigned during my connection and it has worked for me. Now i can stay connected to the internet for about 46 hours uninterruptedly

Bro i have the same problem.i have your model router TP-Link TL-WR740N and have Meghbala Pmpl broadband connection.Please tell me the full procedure bro what u changed.what u did.and how did u increase the address lease time and how u got your dns address that was assigned during your connection please help me bro or else i cannot download a big file using wifi as the net gets automatically log out within 30 mins.Thank you.
 

whitestar_999

Super Moderator
Staff member
in your router wireless dhcp setting change Address Lease Time to 2880 & enter primary & secondary dns values(you can use google dns servers 8.8.8.8 & 8.8.4.4).
 

sbhadra_se

Broken In
in your router wireless dhcp setting change Address Lease Time to 2880 & enter primary & secondary dns values(you can use google dns servers 8.8.8.8 & 8.8.4.4).

Thanx a lot for replying so quick.I followed your instructions, increased the lease time to 2880 and entered my Primary and Secondary dns which was given to me during my connection but still its automatically logging out.because of this i cant even download a big file from my iPad or mobile during the night while i sleep as the net connection automatically logs out after 30 minutes. don't know what to do.
 

sbhadra_se

Broken In
does this problem happens with wired lan connection too?check it.

I tried using LAN still it is logging out.The service guys are not helping me out. This is a service problem i know that still they are telling me to wait 4-5 days.they are saying me this for more than a month.Please whitestar guide me what to do.What can I and what should I do
 

kARTechnology

Sony " VA" "IO"
does your isp use a web based login or u turn on your pc and start browsing immediately?
you can create a script which pings continuously google servers and takes negligible amount of data for doing it. it will ping every 5 mins and you isp sees it as some traffic flowing andf puts your connection alive.

i have made a small script in cmd which uses my isp's 24online client software.
it ping and if it fails, kills the 24online client process and relaunches it, which will auto connect again.
it will check by pinging again. this process continues infinitely.

works rock solid for me. my isp disconnects if there is no activity for more than 30 mins.
 

sbhadra_se

Broken In
My ISP uses a web based login.after I turn on the browser I first login then use the Internet.not directly open the browser and use it.and can u give me the script .. Thanq
 

sbhadra_se

Broken In
Auto Logout 2.jpgThis is the screen shot of my isp login page
 

Attachments

  • Auto Logout.jpg
    Auto Logout.jpg
    70.7 KB · Views: 114
Last edited:
Top Bottom