wrong cpu speed detection in FC6 with cpuspeed daemon

Status
Not open for further replies.

infra_red_dude

Wire muncher!
the problem:
i haf a mobile pentium4 2.8ghz chip in my laptop which actually is a desktop p4 chip and supports the speedstep technology (NOT enhanced ss - multilevel but the p4 ss with 2 levels - 1.6ghz and 2.8ghz). fc6 kernel is 2.6.18-1.2798 (machine - i686, hardware platform - i386) tho the speed is correctly detected at 2799mhz at startup (i can see this wid dmesg | grep MHz), after booting the proc either runs at 668mhz or 692mhz.

solutions tried:
edited the /etc/cpuspeed.conf, enabled the DRIVER=p4-clockmod, upgraded to latest version of cpuspeed for fc6 i386.

observations:
it doesn't help, if i manually "cd" into /sys/devices/......./cpufreq the speed changes to 1.6ghz for a fraction of a second and reverts back to 668mhz. in this directory i can see the available scaling freq as 668000 and 692000.

fix required:
i want the speedstep to correctly work at 1.5g and 2.8g on load. kubuntu used to work perfectly! any help is much appreciated!
__________
edit: i tried cpudyn. the result is same (692mhz). i also tried cpufreqd. but it fails to start up as a daemon. should this be used in conjunction with something?
__________
currently i've disabled all the cpu speed scaling utilities and my system runs at 2.8g wid quite a lot of heat and fans whirling all the while. i had to do this coz the system wud become too sluggish!

anyone else facing this problem wid fc or any other distro?
__________
i'm also not able to activate the pre-configured ondemand perf in the kernel (in cpuspeed)
__________
with the cpufreq-info, i get to see that the driver used is speedstep-smi. but this driver is not present in the /lib/modules/2........../arch/cpu/..../ the only two files i can see are acpi-freq and p4-clockmod.
 
Last edited:

eddie

El mooooo
Could it be that Kubuntu came with a newer kernel version? It seems to be a problem with speedstep module. The little googling I did reveals that the problem was patched on Oct 18 last year and both the distros came after that date but since Kubuntu was supposed to be a little more "on-the-edge" they could have included the patch. Try upgrading your kernel.
 
OP
infra_red_dude

infra_red_dude

Wire muncher!
thanks :)

yes, kubuntu 6.06 has an older kernel.

also, any idea why the cpufreq daemon fails to start? where can i get the error log? one thing i'm not able to understand is that i do not haf speedstep-smi modules in the lib folder. then how can that be loaded?
__________
since the cpu speed scaling is controlled by acpi drivers, cud it be a problem wid those? how do i go about rectifying it?
 
Last edited:

JGuru

Wise Old Owl
@Infra_red_dude, To make the cpufreq daemon start, you have to add it to the "Sessions" -> "Startup Programs".
Someone using Kubuntu can help you on this, since I'm using Ubuntu (GNOME).
 
OP
infra_red_dude

infra_red_dude

Wire muncher!
yes i know that and it is added there. but as a daemon and as a commandline argument, it fails to start and i dunno where to look for the error log.
 

eddie

El mooooo
When you start it as a command line argument...do you get any output on terminal window? Does it crash or gives some error? Does it have a verbose mode?
 
OP
infra_red_dude

infra_red_dude

Wire muncher!
nope it doesn't give any errors. i just invoke the command /etc/init.d/cpufreqd start and it says: failed. thats it.. nothing more!
 

eddie

El mooooo
/etc/init.d/cpufreqd is not the program itself. It is just a startup service of your distro that reads options from a conf file (most probably located in /etc) and tries to start cpufreq demon.

You can try to start the program directly by executing its binary. Just look in the /etc/init.d/cpufreqd file to know where the binary is located and execute it from terminal. That will give you an error.
 
Status
Not open for further replies.
Top Bottom