Why am I gettin this error?

Discussion in 'Software Q&A' started by koolbluez, Dec 26, 2006.

Thread Status:
Not open for further replies.
  1. koolbluez

    koolbluez Šupər♂ - 超人

    Joined:
    Oct 19, 2004
    Messages:
    1,619
    Likes Received:
    50
    Trophy Points:
    0
    Location:
    Look up... up in da sky... see me yet? Nah... Use
    Recently my explorer started playing games with me and displays this message whenever cursor highlights a video file.
    [​IMG]

    I noticed this only when video files are getting accessed by explorer.. something to do with understanding the codec i suppose... what should i do to prevent this?


    Repair solution...


    I've K-Lite installed long back... do u think it must be $crewin the OS? But i never got the prob earlier....
     
  2. mod-the-pc

    mod-the-pc Back to School Mr. Bean !

    Joined:
    Apr 1, 2004
    Messages:
    344
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    Chennai
    Do you have your folder view set to "Tiles" or "Thumbnails"? Try switching it to "Details" view. The preview function in Windows XP seems to be the reason.
     
  3. OP
    OP
    koolbluez

    koolbluez Šupər♂ - 超人

    Joined:
    Oct 19, 2004
    Messages:
    1,619
    Likes Received:
    50
    Trophy Points:
    0
    Location:
    Look up... up in da sky... see me yet? Nah... Use
    Folder view set to default "Icons", but as u pointed out the preview function might have been corrupted by some codec identifying algorithm within some player.
    Is there a simple way of removing this problem... without extensive uninstalling... some debugger?
     
  4. mod-the-pc

    mod-the-pc Back to School Mr. Bean !

    Joined:
    Apr 1, 2004
    Messages:
    344
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    Chennai
    Do you have the same issue in "Details" view and with no preview (the one that appears in the left i.e. Web view as its called in win 98 )?
     
    Last edited: Dec 27, 2006
  5. OP
    OP
    koolbluez

    koolbluez Šupər♂ - 超人

    Joined:
    Oct 19, 2004
    Messages:
    1,619
    Likes Received:
    50
    Trophy Points:
    0
    Location:
    Look up... up in da sky... see me yet? Nah... Use
  6. mod-the-pc

    mod-the-pc Back to School Mr. Bean !

    Joined:
    Apr 1, 2004
    Messages:
    344
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    Chennai
    Go to command prompt and type
    regsvr32 /u shmedia.dll

    This would disable preview for media file

    If you have too many codec packs installed remove all of them, reboot and install any one.

    Try uninstalling the XviD/DivX codec and reinstalling.
     
    koolbluez likes this.
  7. OP
    OP
    koolbluez

    koolbluez Šupər♂ - 超人

    Joined:
    Oct 19, 2004
    Messages:
    1,619
    Likes Received:
    50
    Trophy Points:
    0
    Location:
    Look up... up in da sky... see me yet? Nah... Use
    thnx... that should do it. Any regedit method for the same: regsvr32 /u shmedia.dll

    And what to do to come back to normal... undo this?
    __________

    ok...ok... got it.... to undo just run "regsvr32 shmedia.dll"


    Full thing on media disabling...
    [For others who get similar probs... ya I know most of us musta got this or the file-reading problems frequently]
    To remove image preview, type and hit enter
    regsvr32 /u shimgvw.dll
    To re-add image preview, type and hit enter
    regsvr32 shimgvw.dll
    To remove media preview, type and hit enter
    regsvr32 /u shmedia.dll
    To re-add media preview, type and hit enter
    regsvr32 shmedia.dll

    And yup.. the registry hack which removes the annoying “permission denied” errors when trying to move/copy/delete AVI files.

    To use this fix make a new text file, paste the following code in it, file extension change to inf. Rick click on the file and choose install. Done.

    [version]
    signature="$Windows NT$"

    [DefaultInstall]
    DelReg = Reduce.Reg

    [Reduce.Reg]
    HKLM, “SOFTWARE\Classes\CLSID\{87D62D94-71B3-4b9a-9489-5FE6850DC73E}\InProcServer32”


    In other words...
    1. Open up regedit
    2. Goto HKEY_CLASSES_ROOT\SystemFileAssociations\.avi\shellex\PropertyHandler
    3. Delete the "Default" value which should be "{87D62D94-71B3-4b9a-9489-5FE6850DC73E}"


    Works for this prob too.


    Someone even made a fix-it utility doing the same and uploaded it online!!!


     
    Last edited: Dec 28, 2006
Thread Status:
Not open for further replies.

Share This Page