Weird Harddisk Problem


Broken In
I have 2TB WD (green, 3 yrs old) internal hard disk which I use as backup hdd. I use it as external usb drive.A year ago I backed up all my data (2TB full) in the hdd and kept it in safe place. I was using mac then so it was formatted for mac os. These days I don't use mac so a month ago I backed up all data from that hdd, formatted it as a single partition NTFS drive and again kept all my data there. I am using windows 7.

A week ago I needed some data from the hdd so I used it as a secondary hdd in a windows 7 system. I found that I can copy files from that hdd but at very slow speed. I can write in the hdd at 50-100 MB per second but from the hdd I can copy only at (500KB-1MB) per second. So its like I can write in the hdd much faster than reading. Anyhow I recovered all the important data from the hdd and formatted it. I formatted it as NTFS(quick format), formatted it as FAT32(quick format), tried as desktop hdd, tried it as usb drive, made several partition but still I can't retrieve files from hdd at speed more than 1-2 MB per second.

So guys is there any way I can fix the hdd or its better to throw away as its unacceptable retrieving files at the speed of 1MB per second.. Please reply.

Top Bottom