• CONTEST ALERT - Experience the power of DDR5 memory with Kingston Click for details

Turbo C Problem Help

Status
Not open for further replies.

::vicky::

In the zone
Hi

As You Geeks May Be Knowing About The Compiler Of C/c++ Known As Turbo C .

So The Problem Is When Iam Using Turbo And When I Come Back To Desktop To See The Usage Of Processor It Is 100 % In The Task Manager.

It Is Really Bad And My System Slows Down After That

Plz Note That ::


System Is Free Of Viruses

It Only Happens When I Run Turco C
 

ashu888ashu888

Core i7 (nehalem) Owner
It is normal, coz even i used to get the same message, even while u work in command prompt (for running java compilers like jdk1.2 and above) u will experience sumwat similar information.) So need no worry, wen u are working on C (Turbo C Compiler), the entire CPU usage is dedicate to the compiler.

Cheers n e-peace...
 

Thor

Ambassador of Buzz
U can try onething, when u start tc.exe, hit alt-enter and back to dekstop, using taskmanager, set priority of tc.exe to below normal...it will cause the cpu not to allocate 100% resource to compiler..and in the background u wud be able to listen to music...or do other things...
 

mediator

Technomancer
ashu888ashu888 said:
It is normal, coz even i used to get the same message, even while u work in command prompt (for running java compilers like jdk1.2 and above) u will experience sumwat similar information.) So need no worry, wen u are working on C (Turbo C Compiler), the entire CPU usage is dedicate to the compiler.

Cheers n e-peace...

Thats right!! Dont be paranoid of usage.........YAY!! :p
 
Last edited:

Techinator

Broken In
it never hapened on my desktop but happens on my laptop. and is a very annoying situation. of course setting the priority of the thread to a lower value is one if the options or u can use some windows based IDE like Bloodshed's Dev C++. it is more friendly for programming than the primitive interface of TurboC...
 

47shailesh

Security Exp
ya its true it occured with me too,, compiler takes all cpu and creates a bottle neck for other program,, and even on settng priority of compiler to low no significant change occurs.......
 

sairam999@rediffmail.com

Right off the assembly line
It,s quite normal freind. But the only option is setting priority to less than normal. But, again this will come at the cost of speed of execution (especially for multifile included programs)
 

deathvirus_me

Wise Old Owl
Its time to let go of the DOS based compiler ... Use TC++ 4.5 , or even VC++ 6 .... u can search a bit of that DOS's alternative windows comipler ,.. i think is TCPP v1.01 ...
 
Status
Not open for further replies.
Top Bottom