Opera Temporary files problem

Discussion in 'Software Q&A' started by MenTaLLyMenTaL, Feb 9, 2006.

Thread Status:
Not open for further replies.
  1. MenTaLLyMenTaL

    MenTaLLyMenTaL New Member

    Joined:
    Nov 10, 2005
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    0
    From the 4th of this month, my Opera 8.5 started saving the cached files on the C:\ (root)! - only for my account in XP. For other users, it is saving rightly in the C:\Documents and Settings\user\Application Data\Opera\Opera\profile\cache4

    I tried reinstalling Opera but no use.

    Also, I think this problem is related with:

    I noticed that when i open My Computer, under the 'Files Stored On This Computer', I am seeing only 'Shared Documents' and no other user's documents; not even mine though i can access it from the left pane. The My Documents folder hasnt been deleted or moved. Its intact and all files therein are also as they are. But their shortcuts from My Computer have disappeared.
    My account is a Computer Administrator account. However from the 'administrator' account, all the user's socuments are visible from my computer. But, they are not from other users' accounts.

    It really looks so ugly to have all the cached files right on the C:\.
     
  2. sakumar79

    sakumar79 Active Member

    Joined:
    Nov 28, 2004
    Messages:
    2,445
    Likes Received:
    9
    Trophy Points:
    38
    Location:
    Madurai
    1. Go to C:\Documents and Settings\user\Application Data\ and try renaming Opera to OperaOld and restarting... All custom settings will be lost, but it should recreate your cache directory...

    2. Create a NoSharedDocuments string value in the following registry key and set the data value to 0

    For All Users: Start/Run/Regedit
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

    For Only Users That Are Logged on to the Computer: Start/Run/Regedit
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

    Arun
     
  3. OP
    OP
    MenTaLLyMenTaL

    MenTaLLyMenTaL New Member

    Joined:
    Nov 10, 2005
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    0
    After renaming the Opera folder as u said, it worked. Problem solved for opera.

    But for the My documents problem, I created the value in HKLM. But now, in My Computer, the entire 'File Currently Stored On This Computer' section disappeared (Not even that title there). So i removed the string value. But it didnt reappear!! Now its gone.
     
  4. sakumar79

    sakumar79 Active Member

    Joined:
    Nov 28, 2004
    Messages:
    2,445
    Likes Received:
    9
    Trophy Points:
    38
    Location:
    Madurai
    Good to know first part works...

    Now, on further checking, I see that what I gave was for Shared Documents and not for seeing others documents... After removing the string, did you restart the system? I will check further to see how to get it back if not...

    BTW, for limited accounts, only that user's My documents folder will be seen on that persons My computer... For accounts with admin priviledge, it will show all... If your account is not shown, check HKEY_LOCAL_MACHINE / Software / Microsoft / Windows / Current Version / Explorer / DocFolderPaths to verify if your username and location of my docs is shown in the list...

    Arun
     
  5. OP
    OP
    MenTaLLyMenTaL

    MenTaLLyMenTaL New Member

    Joined:
    Nov 10, 2005
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    0
    No i hadnt restrated system. Neither when i added the strin value, nor when i removed it. but i just checked the my computer again now (w/o restarting), that 'Files stored...' section is back as b4 with only Shared Documents. Maybe it needed some time or a Refresh hehe.

    One thing i hadnt mentioned in my 1st post is that, er i'll list the accounts on xp to make it simpler; these are the accounts on the computer -

    Administrator - admin
    Sagar (me) - admin
    Chan - User
    Suneeta - user
    Vivek - User

    1) From Administrator, i can see all the user's documents in My Computer.
    2) From Sagar - only Shared Documents
    3) From Chan - Shared Documents & Chan's Documents
    4) From Suneeta - Shared Documents & Chan's Documents !!! (not a typo)
    5) From Vivek - Shared Documents & Chan's Documents !!! (not a typo)

    The Suneeta and Vivek accounts are never or hardly used.

    And i have checked HKLM/.../DocFolderPaths. I have a lil doubt - When i'm logged in as Sagar and see the different document folder of users from C:\Documents and settings\user, it shows as "User's Documents" and not My Documents. And in the DocFolderPaths its "C:\Docu....\My Documents". I beleive it is correct.
     
  6. sakumar79

    sakumar79 Active Member

    Joined:
    Nov 28, 2004
    Messages:
    2,445
    Likes Received:
    9
    Trophy Points:
    38
    Location:
    Madurai
    Regarding the last statement, that is how winxp will display the folder name, so dont worry...

    Will check up the other part and get back to you...

    Arun
     
  7. sakumar79

    sakumar79 Active Member

    Joined:
    Nov 28, 2004
    Messages:
    2,445
    Likes Received:
    9
    Trophy Points:
    38
    Location:
    Madurai
    Do check this:
    In each user's My Documents folder and subfolders, open the Desktop.ini files and modify the Owner value under the "DeleteOnCopy" section to match the user name

    Arun
     
  8. OP
    OP
    MenTaLLyMenTaL

    MenTaLLyMenTaL New Member

    Joined:
    Nov 10, 2005
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    0
    All the desktop.ini files are correct.
     
Thread Status:
Not open for further replies.

Share This Page