Mounting partitions in Ubuntu

Discussion in 'Open Source' started by thilina, Jun 11, 2009.

Thread Status:
Not open for further replies.
  1. thilina

    thilina From Sri Lanka

    Joined:
    Aug 19, 2006
    Messages:
    171
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Sri Lanka
    Guyz,
    Hw can I make ma partitions mount automatically when Ubuntu starts??I've Ubuntu 8.10 & it doesnt do so.
     
  2. ThinkFree

    ThinkFree New Member

    Joined:
    Jan 11, 2007
    Messages:
    2,426
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Lat 28.38°N , Longt 77.13°E
    You have to modify /etc/fstab file for that.
     
  3. OP
    OP
    thilina

    thilina From Sri Lanka

    Joined:
    Aug 19, 2006
    Messages:
    171
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Sri Lanka
    gud answer!! :p
    I knw dat I need to modify dat.Bt Hw??
     
  4. NucleusKore

    NucleusKore TheSaint

    Joined:
    Jun 19, 2004
    Messages:
    3,435
    Likes Received:
    2
    Trophy Points:
    0
    Location:
    Antigua
    What partitions? Windows ntfs? Download ntfs-config using Synaptic.

    Click Applications->Accessories->Terminal

    Type
    sudo ntfs-config
    and press ENTER.

    Key in your password and press ENTER.

    Mark the drives you want to mount. Click the mount point option in that and type c or d or any other name you want to recognise that partition by.
     
  5. OP
    OP
    thilina

    thilina From Sri Lanka

    Joined:
    Aug 19, 2006
    Messages:
    171
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Sri Lanka
    Fat32 & NTFS

    When i click on them in the Gnome menu they get mounted.Bt I need them to get mounted when ubuntu starts up
     
  6. ThinkFree

    ThinkFree New Member

    Joined:
    Jan 11, 2007
    Messages:
    2,426
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Lat 28.38°N , Longt 77.13°E
    /dev/sda1 /media/windows/ ntfs defaults,auto,user,rw 0 0

    Add this entry to /etc/fstab if you want to mount your first partition at /media/windows folder in linux. /media/windows directory is required to be created first. See man pages for more details.
     
  7. OP
    OP
    thilina

    thilina From Sri Lanka

    Joined:
    Aug 19, 2006
    Messages:
    171
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Sri Lanka

    Thx frnds.Ill chk dz n tell u d results tomorrow. Tl den bye :razz::razz::razz:
     
  8. OP
    OP
    thilina

    thilina From Sri Lanka

    Joined:
    Aug 19, 2006
    Messages:
    171
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Sri Lanka
    K guyz I tried it,bt small problm.

    K guys this is ma original fstab file

    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    # /dev/sda5
    UUID=9fddddd6-8a3f-4a3b-a2d5-51b7056fcdab / ext3 relatime,errors=remount-ro 0 1
    # /dev/sda6
    UUID=782d7344-82c1-4d65-93cd-a3f5332c43be none swap sw 0 0
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0



    Then after I edited it it looks like this.

    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    # /dev/sda5
    UUID=9fddddd6-8a3f-4a3b-a2d5-51b7056fcdab / ext3 relatime,errors=remount-ro 0 1
    # /dev/sda6
    UUID=782d7344-82c1-4d65-93cd-a3f5332c43be none swap sw 0 0
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0

    /dev/sda1 /media/WINDOWS ntfs defaults,auto,user,rw 0 0

    /dev/sda7 /media/DATA vfat defaults,auto,user,rw 0 0

    /dev/sdb6 /media/EXTRA vfat defaults,auto,user,rw 0 0

    /dev/sdb5 /media/SHARED vfat defaults,auto,user,rw 0 0[/FONT]


    Nw all the partitions get mounted on the startup without any problms.Bt I (in ma account) cnt write to Vfat partitions in ma pc.Bt cn write to NTFS partitions via my account.Bt as Root I can write to all the partitions with no problems.What shud I do for this?
    :?
     
  9. NucleusKore

    NucleusKore TheSaint

    Joined:
    Jun 19, 2004
    Messages:
    3,435
    Likes Received:
    2
    Trophy Points:
    0
    Location:
    Antigua
    to defaults,auto,user,rw add umask=0002
    so that looks like
    defaults,auto,user,rw,umask=0002
     
  10. NucleusKore

    NucleusKore TheSaint

    Joined:
    Jun 19, 2004
    Messages:
    3,435
    Likes Received:
    2
    Trophy Points:
    0
    Location:
    Antigua
    to defaults,auto,user,rw add umask=0002
    so that looks like
    defaults,auto,user,rw,umask=0002
     
Thread Status:
Not open for further replies.

Share This Page