Galaxy Y weird problem


Geek v1.0
I have a weird problem on my galaxy Y

Here's an explanation step by step

1. Want to call person A . Went to the log , swiped the person(or dialled the no.) which I want to call. Dialling didn't happen and phone returned to home screen.

2.Ok now want to call person B. Insured of calling B the phone dials person A's no.

I tried clearing up some space on phone memory, sd card, cleared ram.
Still this issue persists. I am using Galaxy Y S5360 with stock rom , non rooted.

3.Connects to wifi but doesn't work(so I cannot update on data)

Something like the calling problem happens on my dad's galaxy pocket also. Both have android 2.3.6 with samsung touchwiz.


Can you move the dialler back to the 'normal' internal storage and not the EXT3/EXT4 partition. Some system apps have gone mad for me over time when Link2SD was used. What ROM are you running? Also have you tried downloading an alternative Dialler to see what happens? Just as a baseline. Do you have a logcat from the device to see if something is happening?


Geek v1.0
Tried clearing dialer data. Didn't worked. Running stock rom, no roots

I did a factory reset and will see if the issue still persists.
Top Bottom