Enable DMA in DVD drive

Discussion in 'Hardware Q&A' started by guhanath, Feb 28, 2006.

Thread Status:
Not open for further replies.
  1. guhanath

    guhanath Member

    Joined:
    Jan 3, 2005
    Messages:
    97
    Likes Received:
    0
    Trophy Points:
    6
    Hi All,

    I want to know to enable DMA in DVD drive.My PC configuration is this

    AMD Athlon 64 3200+
    Asrock K8 Combo-Z
    512 Mb DDR
    LG DVD(GDR-8163B)
    LG CDRW(GCE-8527B)
    Nero 6 Installed.

    Whenever I try to write CD's Nero says that DMA is not enabled for DVD drive.
    However I checked in Device Manager that both CDRW and DVD IDE channels use DMA
    I tried to enable DMA in Nero "DMA Manager",it accepts and inform me to
    restart the system which I did.Even after restart Nero is not indicating the DVD drive as DMA Ready

    what could be the problem.Please help me sort this out.

    Regards
    Guhan
     
  2. readermaniax

    readermaniax New Member

    Joined:
    Jul 19, 2005
    Messages:
    553
    Likes Received:
    0
    Trophy Points:
    0
    Enabling DMA access for your DVD-ROM increases its speed. DMA access is supported by most new DVD-ROM Drives.

    Click on CONTROL PANEL | SYSTEM | DEVICE MANAGER

    Now select your DVD-ROM Drive and go to PROPERTIES and you will see an area like the image below

    [​IMG]

    Next click on the DMA Box and make sure it is now ticked....Then finally you will need to restart your PC for this to take effect. You do not need to worry about this damaging your drive because if this option is supported by your DVD-ROM then the DMA Access will remain ticked, if the box un-ticks itself after the reboot, your DVD-ROM Drive does not support DMA Access[/img]
     
  3. OP
    OP
    guhanath

    guhanath Member

    Joined:
    Jan 3, 2005
    Messages:
    97
    Likes Received:
    0
    Trophy Points:
    6
    Hi ,
    I have checked in the "Device manager" and both Primary and Secondary IDE channels show that "DMA is enabled" but only Nero is not able to detect that.what should I do?

    Regards
    Guhan
     
  4. readermaniax

    readermaniax New Member

    Joined:
    Jul 19, 2005
    Messages:
    553
    Likes Received:
    0
    Trophy Points:
    0
    Then i thnik theres somthin wrong with NERO or the Disc you are using to write .. try to write files on some other CD maybe SONY will do ... or then you can uninstall NERO then delete the registry related to nero and then try installing nero again. Make a backup befor plaing with registry!!!
     
  5. AcceleratorX

    AcceleratorX Member

    Joined:
    Jun 19, 2005
    Messages:
    723
    Likes Received:
    14
    Trophy Points:
    18
    Location:
    The New World Order
    I've had this bug on Windows XP. Try this:

    1)Update Nero to the latest version
    2)Uninstall the Primary and Secondary IDE channel
    3)On restart, let Windows redetect your hard disks and CD/DVD drives.

    This happens because certain damaged discs can cause Windows to revert a drive back to PIO mode even if there is no problem with the drive (a stupid feature to "Protect" the drive by Microsoft, the drive is changed to PIO mode after a specific number of errors occur during the reading of a disc at a given time period). This change may not be detected by the drivers, due to which it still reports DMA. But Nero may be doing a different sort of check which determines the actual speed.

    This worked for me on XP.
     
Thread Status:
Not open for further replies.

Share This Page