Deleted boot.ini

Status
Not open for further replies.

taurius1

Broken In
My brother very nicely deleted my boot.ini. <_<
Kept getting the error BEFORE OS choices saying "NTLDR not found"

Anyways.. I looked up some stuff online, and found this awesome site that deals with just about all cases.... http://ntldrismissing.com/ (nice name, eh? :p)

Back to the problem... I used the ntldrusb.zip file's contents to make my PC work again... I plugged in my non-working PC's HDD to my owrking PC as a slave and just pasted those files there in C:\

Now, the boot.ini he's mentioned is as follows:

Code:
[Boot Loader]
timeout=30
Default=multi(0)disk(0)rdisk(0)partition(1)\WINXP

[Operating Systems]
multi(0)disk(0)rdisk(0)partition(1)\Winxp="1ST TRY THIS " /fastdetect
multi(0)disk(0)rdisk(1)partition(1)\Winxp="2ND TRY THIS" /fastdetect
multi(0)disk(0)rdisk(0)partition(2)\Winxp="3RD TRY THIS" /fastdetect
multi(0)disk(0)rdisk(1)partition(2)\Winxp="4TH TRY THIS" /fastdetect
multi(0)disk(0)rdisk(0)partition(3)\Winxp="5TH TRY THIS" /fastdetect
multi(0)disk(0)rdisk(1)partition(3)\Winxp="6TH TRY THIS " /fastdetect
multi(0)disk(0)rdisk(0)partition(4)\Winxp="7TH TRY THIS" /fastdetect
multi(0)disk(0)rdisk(1)partition(4)\Winxp="8TH TRY THIS" /fastdetect
C:\="9TH TRY THIS"
D:\="10TH TRY THIS"
G:\="11TH TRY THIS"

Messy, right? ( I added G:\="11TH TRY THIS" on my own.. reason given below)

But it worked. Only the 1st option works, but that was enough to get my PC to boot again.

I clipped the file to
Code:
[Boot Loader]
timeout=30
Default=multi(0)disk(0)rdisk(0)partition(1)\WINXP

[Operating Systems]
multi(0)disk(0)rdisk(0)partition(1)\Winxp="1ST TRY THIS(Windows XP 32)" /fastdetect
multi(0)disk(0)rdisk(1)partition(1)\Winxp="2ND TRY THIS " /fastdetect
G:\="3RD TRY THIS"

Now, besides having Windows XP intalled on C:\ [fat32] , which the 1st boot path points to,
I also have Windows XP Pro (64bit) installed on my G:\ [ntfs]

None of the paths mentioned in the boot.ini let me boot my 64 bit OS up.

I would request someone who can help, to give me the boot.ini entry to allow me to boot up my 64-bit OS.

Thank you. ^_^
 

kaustav_geek

1337 |)00|) \m/
Click Here
How many partitions do you have ? if you have ,say 5, then paste this
Code:
multi(0)disk(0)rdisk(0)partition(2)WINDOWS="XP x64 " /fastdetect /
NoExecute=OptOut

And replace the "partition(2)" with the corresponding partition number, on which Win XP x64 is installed.
I'm not sure, but it might work

Next time when your brother comes near your PC, give him a death-threat. :D
 
OP
T

taurius1

Broken In
I have 5 partitions... C:\ all the way to G:\ and G:\ is the one where i've installed XP 64

another question... what does "/NoExecute=OptOut" do?
 

arun77574

Broken In
Do the repair installation. All missing files will be automatically restored without any data loss. Since you have dual OS istalled you'll have to do it twice with the respective Setup discs, i mean the Xp and Xp pro 64-bit.
 

sakumar79

Technomancer
Are all five partitions on same HDD? Then you should use partition(4)... But if it is on two Hard disks, you have to put disk(1) or rdisk(1), not sure which and then partition (n-1) when G is the nth partition on the second hdd..

Arun
 
OP
T

taurius1

Broken In
Using the boot.ini entry that kaustav_geek gave me didnt work at all. Looking up stuff on the internet, i found out that boot.ini does not support more than 4 partitions. So, I tried setting rdisk(1) and disk (1) [I got the idea from what I know about RAID and it's configuration I learnt in college this year. XD Wow... education did make a difference. XD ]
@sakumar79 Looks like we both had the same idea in mind, but it didnt work. :) And yes, all my 5 partitions are on the same HDD


Next thing I tried running a recovery console thingie... with "bootcfg /rebuild" but it did not help.


So, as a last resort, I used my XP 64 installation disk. Running a repair from the installation disk of WinXP 64 fixed my boot.ini file. :D

Thanks for your input though, guys!


Oh, incase you guys are wondering, my boot.ini file now looks like:

Code:
[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows XP Pro" /fastdetect
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Windows XP Professional x64 Edition" /noexecute=optin /fastdetect

I guess the second OS partition is always set as partition (2) in bios, no matter what it's drive letter / physical location is on the HDD. :)



Closing notes: Time taken to bring my system back online: 7 hours. Including breakfast and a 2 hour nap, and two glasses of lithchee cremosa.
Stuff I tried:
Shifted my internet connection to the other PC. Found replacement boot.ini and other associated files. Tried booting from those from a USB drive. Did not work.
Paniced. Posted here. XD
Shifted my HDD to my other PC. Manually placed boot.ini file and other associated stuff into C:\ Only one OS worked.
Messed with boot.ini a bit more.
Gave up hope of a simple solution.
Ran repair from installation disk.
Did a small victory dance.
Made last spam post here.




P.S. I love these forums. I don't need to be a regular member here to get abuse-free advice. :p

Thank you all. Please close this thread as my issue has been resolved. :)
 
Last edited:

kaustav_geek

1337 |)00|) \m/
Code:
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows XP Pro" /fastdetect
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Windows XP Professional x64 Edition" /noexecute=optin /fastdetect

Bro, check out the code I gave once again carefully. The one you have now, is almost identical to the one I gave... I don't know why It didn't work...
 
Status
Not open for further replies.
Top Bottom