Wi-Fi doesn't have a valid IP configuration error

OP
B

billubakra

Conversation Architect
@whitestar_999
Again following this link FIX: Wi-Fi doesn’t have a valid IP configuration and this
Followed first point again, result


No gateway shown in ipconfig /release
umable to contact your dhcp server error in wifi.

The same wifi, connected via hotspot from a phone, is working fine in 10+ devices

The last update was downloaded like in first week of July. It always used to show me a notification to install it. But I kept on ignoring it and put the laptop in sleep mode. Now after the system froze and I restarted it, that update was gone. It didn't install as there was no sign of the installation windows. Now the update history shows me the last update which was installed in June. I cannot revert it back because it has been more than 10 days. The update page shows me a new update but I cannot download and install it as I cannot connect to the internet. Where are the downloaded update files stored? Can I install the last update which was downloaded and I delayed it, manually?
Reinstalling the Windows will be a mess as it is a work laptop.
 
OP
B

billubakra

Conversation Architect
@whitestar_999 @khalil1210

Followed these steps one last time, please check the screenshots

a. Windows 10 "ipconfig /renew" not working
Your wireless LAN adapter Wifi does have an IP address. ipconfig /renew will not renew adapters that have no connection. Every computer with wireless and an Ethernet port will have an error like this if they are not both connected.


b. I get an error "media disconnected" when I try to renew the IP address and the network connection shows as disconnected.
netsh winsock reset
netsh winsock reset catalog
netsh int ip stop
netsh int ip start



c. FIX: Wi-Fi doesn’t have a valid IP configuration
Followed the commands in step 2
netsh winsock reset
netsh int ip reset



Then followed this Netsh int ip reset says access denied


And then it showed this

Then followed these commands from the same link (enabled all other adapters)
ipconfig/release
ipconfig/flushdns
ipconfig/renew


Result-


Please check this too
 
OP
B

billubakra

Conversation Architect
@billubakra , If it is a office laptop, why bother troubleshooting. Raise a concern, they will take the headache of fixing it or replacing it
Laptop is mine but it has some official softwares. I can get the same installed only by visiting the main office, no remote support. Moreover I will have to give a reason for this.
 

whitestar_999

Super Moderator
Staff member
I think after the initial error you should have waited before trying so many fixes. I think it has messed up your windows networking configuration & registry settings.
 
OP
B

billubakra

Conversation Architect
I think after the initial error you should have waited before trying so many fixes. I think it has messed up your windows networking configuration & registry settings.
Any way to fix the same? Did you check this post? Wi-Fi doesn't have a valid IP configuration error

Few services were stopped, few were set to manual. Enabled them all and set them all to automatic What are the bare services and components needed for WiFi?

Screenshot of the system restore, I didn't create one. It seems it was made automatically
Any tips for this?

I am so tired. Just check these one's
Screenshots from the laptop




From the pc



Hope 802.11n and 802.11bgn isn't the issue
 
OP
B

billubakra

Conversation Architect
Compare the above & you will what the problem is, your laptop is not getting any IPv4 address when set in auto mode/DHCP enabled. It is as if ipv4 isn't even there.
Yes I noticed that too.

Connected the phone to the laptop via usb cable, usb tethering that is and got this



Later on it changed to unidentified network like it does with the wifi


Again no sign of the ipv4. Any help?
 
OP
B

billubakra

Conversation Architect
See this thread & confirm that ipv4 is ticked/checked in connection properties.
It is exactly like shown in that thread.

This is the registry level thing which I followed and which might have messed up things even more

Edit-
Another major change which I did was set all services mentioned here to running and to automatic
Just after restarting the laptop after doing these settings the wifi showed as connected on the login page where we enter the password and after logging in, it was back to square one.
 
Last edited:
OP
B

billubakra

Conversation Architect
@whitestar_999
Advanced settings of ipv4




ipv6


Hope these settings are fine




These below are showing ipv4 in the laptop, well in a way





Same thing from a pc connected to the same hotspot, lease obtained and expires is also not there in the laptop's case



 

whitestar_999

Super Moderator
Staff member
Same thing from a pc connected to the same hotspot, lease obtained and expires is also not there in the laptop's case

This is showing a different gateway & ip range(192.168.88.x) which is different from earlier 192.168.18.x. This is why when you manually set ipv4 net is not working because for net to work your manually entered ip & gateway must be within ip range of first three sets of dhcp server of the device you are connecting to. In case of wifi routers this range is fixed so it is easy to manually set ip but here it seems phone keeps changing this range so not possible to manually set ip to get net working. As for DHCP in your laptop, it is clearly not working correctly which is the cause of this entire issue.

I suggest to try that win 10 restore point to see if it helps but no guarantees, you may have to even reset entire windows(next best option to format & reinstall) to undo all the changes/fixes/updates.
 

whitestar_999

Super Moderator
Staff member
Does this require any installation cd or pendrive as mentioned in point 5
It may depending on whether there is a proper recovery environment/oem recovery partition present in your laptop. If you do need installation DVD then get it from here:
 
OP
B

billubakra

Conversation Architect
It may depending on whether there is a proper recovery environment/oem recovery partition present in your laptop. If you do need installation DVD then get it from here:
Reset seem to have solve this but all my files are gone besides the fact that I chose to keep the files. Still testing. Anyways few issues a new admin account has been auto created




I can disable it using the cmd method as shown here https://www.technipages.com/windows-administrator-account-login-screen but the same stays there on the lock screen. It vanishes from the user accounts also How to Delete Administrator Account in Windows 10 : HelloTech How


Anyways this admin account is the reason that I am getting errors like this while installing softwares from my primary and only account

How to fix delete this administrator account?


This article says to fix it with gpedit.msc When I run this command I get this error https://imgur.com/a/7ErRfkN Reset not done properly?

Thanks bro.
 
Top Bottom