1. Hi Guest
    We are running a survey about laptop service in India, and we'd love your inputs. Please help us improve the quality of laptop servicing, and if you've had any bad experiences, now is the time to be heard.
    Take the survey

Western digital 3tb external my book hdd?

Discussion in 'Hardware Q&A' started by GEEKCOMPUTER_GEEK, Jun 13, 2015.

  1. GEEKCOMPUTER_GEEK

    GEEKCOMPUTER_GEEK Member

    Joined:
    Mar 8, 2009
    Messages:
    287
    Likes Received:
    0
    Trophy Points:
    16
    Hello,
    to all of you.
    I just recently bought a new 3TB My Book Western Digital external Hdd, whenever I start this hdd in normal mode of Windows 7 64 bit, it takes too much time to initialize the whole directory structure so that I can use, even sometimes its light blinks for the whole night and I am unable to use any of its files or folders, but whenever I start in safe mode and try to access this drive, it opens and start working like a normal drive, I am unable to figure out the problem, I have checked the drive with Western Digital Utilities, everything comes fine, I also checked the drive with Disk Checker with that also everything comes fine, I've updated the SES 64 bit driver, but all fails.So, please advice what to do?
    Regards,
    GEEKCOMPUTER_GEEK
     
  2. aswin1

    aswin1 Member

    Joined:
    Mar 20, 2008
    Messages:
    187
    Likes Received:
    0
    Trophy Points:
    16
    Since it works fine in safe mode it may be the antivirus or some similar software which is blocking the drive. Try connecting it with antivirus
    and firewall disabled. Also try connecting it in a back USB port as those in front sometimes give errors.
     
  3. OP
    OP
    GEEKCOMPUTER_GEEK

    GEEKCOMPUTER_GEEK Member

    Joined:
    Mar 8, 2009
    Messages:
    287
    Likes Received:
    0
    Trophy Points:
    16
    Hello,
    Thanks for reply, actually I use laptop, yeah it is some software that block the drive.
    GEEKCOMPUTER_GEEK
     
  4. DK_WD

    DK_WD WD Official

    Joined:
    Sep 9, 2014
    Messages:
    362
    Likes Received:
    2
    Trophy Points:
    0
    Location:
    Singapore
    Hi [MENTION=69089]GEEKCOMPUTER_GEEK[/MENTION].

    As per aswin1 update, I agree with him. The problem persists because of firewall or any other software in a system. I'd suggest you some basic troubleshooting options that may help you to solve the problem.

    Options:

    Try to disable the Windows indexing option, Antivirus and change the Firewall settings.

    I'd like to ask you, if you found the software that is causing the problem with the slow initialization; please share with us.
     
  5. OP
    OP
    GEEKCOMPUTER_GEEK

    GEEKCOMPUTER_GEEK Member

    Joined:
    Mar 8, 2009
    Messages:
    287
    Likes Received:
    0
    Trophy Points:
    16
    Hello,

    I still didn't find the software or setting that is causing the problem, but the strange thing is that I have My book Essential 2tb attached to the same system and enabled the Windows indexing option as well as other options like Anitvirus and Firewall and that work very much fine, but I don't know What is going on with this 3tb My book hdd? I bought this hdd on your advice, you told me that Go for My Book instead of My Book Essential, because My Book is the latest version from Western Digital, when I first connect this drive to the system, that same time this problem starts, now, I am feeling I did a mistake buying My Book, anyways.
    GEEKCOMPUTER_GEEK
     
  6. TheHumanBot

    TheHumanBot Member

    Joined:
    Sep 6, 2008
    Messages:
    834
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Gujarat, India
    try updating your windows.
     
  7. DK_WD

    DK_WD WD Official

    Joined:
    Sep 9, 2014
    Messages:
    362
    Likes Received:
    2
    Trophy Points:
    0
    Location:
    Singapore

    Hi [MENTION=69089]GEEKCOMPUTER_GEEK[/MENTION],

    Based on your post, the problem is not on the external hdd's end, but rather, on the Operating System's end because the device can be accessible in safe mode. I’d suggest you some options that may help you to narrow down the issue on the computer's end.

    Option 1:

    Try a different Computer to make sure that the problem is with the device and not with the PC. You could probably try this first if you know of another computer to try out right now.

    Option 2:

    Try to run in "clean boot". With that, you might find the cause and fix it.

    Please refer the below link for Clean boot settings, and more importantly, how to find out what the problem is once you're in clean boot:

    How to perform a clean boot in Windows

    Option 3:

    Try to create a new user profile in windows with administrator rights and try to access the drive. This is kind of like a fresh start with your computer without the extreme step of reformatting and reinstalling windows.

    Good luck and keep me posted.
     
  8. OP
    OP
    GEEKCOMPUTER_GEEK

    GEEKCOMPUTER_GEEK Member

    Joined:
    Mar 8, 2009
    Messages:
    287
    Likes Received:
    0
    Trophy Points:
    16
    Hello,
    DK_WD,
    I am unable to find the problematic service which causes all the problem, but with some software I just start the computer with much of the services with the delayed start option, and drive seems working fine, now, I'll try more and then let you know.Thank You.
    Regards,
    GEEKCOMPUTER_GEEK
     
  9. DK_WD

    DK_WD WD Official

    Joined:
    Sep 9, 2014
    Messages:
    362
    Likes Received:
    2
    Trophy Points:
    0
    Location:
    Singapore
    Sure, let us know the status and I will try my best to help you on this matter.
     

Share This Page