• CONTEST ALERT - Experience the power of DDR5 memory with Kingston Click for details

Weird problem with Lava a10 phone-help needed.

quicky008

Technomancer
I have been using a lava a10 handset for the last couple of months,although its quite a run of the mill device,it has worked satisfactorily so far.Recently i inserted a docomo sim card in the 2nd slot within the phone(there was a uninor sim in the first slot) and tried to use it in dual sim mode.But as soon as i turned it on,the screen flickered incessantly for a while and the phone became unresponsive shortly thereafter.Then turned it off and switched the position of these sim cards(i.e. i put the docomo sim in the 1st slot & the uninor in the 2nd one) and switched it back on again-quite surprisingly it worked normally this time and i could make and receive calls using both sims.

To test the phone,i inserted 2 sim cards from aircel and vodafone,one after another in the 2nd slot but the phone worked just fine on both occasions.But whenever the docomo sim card was put into the 2nd slot,this problem cropped up for no apparent reason;quite inexplicably,the phone worked normally when this sim card was inserted in the first slot(I've verified this using two different docomo sims to eliminate the possibility of the sim card being faulty).

Although its still under warranty,i am not very keen on taking it to a service centre as I've heard that lava usually provides poor after sales service.Does anyone have any idea as to the cause of this problem?Any help in resolving this issue will be greatly appreciated,thanks.
 
Top Bottom