Problem with Android One


Gadget Freak
I got this problem with play store downloads on my micromax canvas A1.
I believe this problem is common to all canvas A1.

I have 2 micromax canvas A1 devices, one xiaomi and samsung , lg and so on..

Whenever I try to download anything above size ( ~ 4 mb ), I receive an error message saying " could not be downloaded error 489 ".

I tried on both canvas a1 devices , the result is same resulting in error 489.

First I thought this is my wifi problem. So, I tried in my other samsung, xiaomi and LG devices but theres no problem as such. The app installs just fine.

I already tried following steps but nothing helped.

1) Factory reset devices ( DIDN'T WORK.)
2) Installed new version of play store ( DIDN'T WORK)
3) Removed google a/c >> reboot >> clear play store data . (DIDN'T WORK)
4) Cleared play store data >> cleared google service framework data >> play store services data . ( DIDN'T WORK )

I TRIED EVERYTHING MENTIONED on google search but nothing worked.

Someone plz confirm this on their devices.

- - - Updated - - -

Saw karbonn Sparkle has same problem like Micromax Canvas A1. This issue is just too annoying. I am considering returning it


Bro I got my spice dream uno yesterday and have downloaded appa from play store without issues.

Have you tried to remove updates from play store and then tried again?
Can you tell me the names of the apps that give you the issue?


Cyborg Agent
Android 1 is crap , even if you used to 2.3 or 4.0

Really man, you know what you are saying, Its a good initiative by Google and it will force all big mobile companies to design phone for the market like india, there are excellent reivews of these devices, no offence, but you gotta know you saying brother


Firecracker to the moon
Go to your phone’s Menu > Settings > Accounts
Tap in the Google you’ll see there.
Tap in the options icon, and click on Remove account.
Confirm that you want it.
After you’re done, reboot your device, and add your google account again.
Go to Settings > Applications manager > Google Play Store and clear the data.

This has to work it solved the problem for me in my nexus 10
Top Bottom