PC hang single time every time power on

surya_sapui

In the zone
Dear Guys,

when I start pc then on login screen pc getting hang. But after restart no problem even after 2-3 hours., on the next day when I start again the same problem appear after restarting no problem.

kindly suggest the resolution.

Configuration :
CPU: AMD FX-8350
Motherboard: SABERTOOTH 990FX
Graphics: ATI Radeon RX 580 Series 8gb
Storage :
59GB M4-CT064M4SSD2 (SATA (SSD))
931GB Western Digital WDC WD10EARS-00MVWB0 (SATA )
465GB Western Digital WDC WD5000AAKX-00PWEA0 (SATA )
465GB Seagate ST500DM002-1BD142 (SATA )
931GB Seagate ST31000528AS (SATA )
Ram :
Slot #1
Type DDR3
Size 4096 MBytes
Manufacturer Corsair
Slot #2
Type DDR3
Size 4096 MBytes
Manufacturer Corsair
Slot #3
Type DDR3
Size 2048 MBytes
Manufacturer G.Skill
Slot #4
Type DDR3
Size 2048 MBytes
Manufacturer G.Skill


Optical Drives : HL-DT-ST BD-RE WH16NS40
Audio :Sound Blaster Z
OS:Windows 10 Pro 64-bit version 1909
 
Last edited:
OP
S

surya_sapui

In the zone
Post screenshot of startup tab in task manager.

upload_2020-2-8_22-41-35.png
 

meetdilip

Computer Addict
Try resetting your PC. I won't force it on you, but that could fix it.

Use " Keep files " option. Take backups.
 

patkim

Cyborg Agent
Since you have Windows 10, is Fast Startup or Fast Boot enabled in the UEFI (BIOS) and / or in the Power Options? Fast Boot is applicable during Shutdown and Start but is ineffective during Restarts. Try disabling this setting in both places and test again.
Restart at least 30 - 40 times to confirm that it's not by chance but indeed the issue is at Cold Boot but not Warm Boot.

Enable Hibernate. Hibernate your PC and start again and see if the issue repeats when it Hibernates and resumes again, and report the updates here.

Set UEFI settings to Optimized defaults in the UEFI (BIOS) Settings.

If there's a specific switch that enables Windows 10 WHQL support (or a switch to set OS as Windows 8/10) in the UEFI, disable the same and let it switch to traditional VGA. It has no impact on the usual functionality of the Windows 10. It just disables certain advanced UEFI features that Windows 8 and above support. If you have set to boot in UEFI mode, it will still work even if this switch is disabled in UEFI.

If your account is protected by password at login, temporarily disable the password and let it automatically boot to desktop and see where it hangs now.
 
Last edited:
OP
S

surya_sapui

In the zone
Since you have Windows 10, is Fast Startup or Fast Boot enabled in the UEFI (BIOS) and / or in the Power Options? Fast Boot is applicable during Shutdown and Start but is ineffective during Restarts. Try disabling this setting in both places and test again.
Restart at least 30 - 40 times to confirm that it's not by chance but indeed the issue is at Cold Boot but not Warm Boot.

Enable Hibernate. Hibernate your PC and start again and see if the issue repeats when it Hibernates and resumes again, and report the updates here.

Set UEFI settings to Optimized defaults in the UEFI (BIOS) Settings.

If there's a specific switch that enables Windows 10 WHQL support (or a switch to set OS as Windows 8/10) in the UEFI, disable the same and let it switch to traditional VGA. It has no impact on the usual functionality of the Windows 10. It just disables certain advanced UEFI features that Windows 8 and above support. If you have set to boot in UEFI mode, it will still work even if this switch is disabled in UEFI.

If your account is protected by password at login, temporarily disable the password and let it automatically boot to desktop and see where it hangs now.


Sorry for the late reply, Due to bad health I can't sit in front of the pc.

After your reply I thoroughly examine bios but i didn't find any Fast Startup or Fast Boot enabled in the UEFI (BIOS) also I didn't find any UEFI settings in bios.

that's why I upload every bios page with sub-menu. kindly check if any wrong settings in bios.
Also when I start pc today only for a few seconds it's hang & display gone after a few seconds its normal.

 

patkim

Cyborg Agent
Wish you a speedy recovery from your ill health!

Though not relevant, I notice that you have XHCI Handoff Disabled in your BIOS. In that case your USB 3ports will operate at USB 2 speeds. To get max throughput from USB 3 ports, enable this setting.

You are in EZ mode. Switch to Advanced Mode and see if such hidden settings related to Fast Boot/OS Selection are visible. However, it appears to me that this board was released prior to Windows 8 so such setting related to Fast Boot / OS Selection might not be present. Apparently, every BIOS is different!

Even if you do not have Fast Boot/Fast Startup setting in BIOS, it may still be there in Windows 10 Power Options, if so, check & Disable the same in Control Panel --> Power Options --> Choose What power buttons do --> ‘Change Settings that are currently unavailable’.

What happens if you boot a Live CD like Hiren Boot DVD of Windows 10?

If your PC has now started to show some other symptoms, like random hang / blank display etc then it might also be indicative of possible underlying hardware issue unless you have also tried clean reinstall or drivers install/upgrade.
 
Last edited:
OP
S

surya_sapui

In the zone
Wish you a speedy recovery from your ill health!

Though not relevant, I notice that you have XHCI Handoff Disabled in your BIOS. In that case your USB 3ports will operate at USB 2 speeds. To get max throughput from USB 3 ports, enable this setting.

You are in EZ mode. Switch to Advanced Mode and see if such hidden settings related to Fast Boot/OS Selection are visible. However, it appears to me that this board was released prior to Windows 8 so such setting related to Fast Boot / OS Selection might not be present. Apparently, every BIOS is different!

Even if you do not have Fast Boot/Fast Startup setting in BIOS, it may still be there in Windows 10 Power Options, if so, check & Disable the same in Control Panel --> Power Options --> Choose What power buttons do --> ‘Change Settings that are currently unavailable’.

What happens if you boot a Live CD like Hiren Boot DVD of Windows 10?

If your PC has now started to show some other symptoms, like random hang / blank display etc then it might also be indicative of possible underlying hardware issue unless you have also tried clean reinstall or drivers install/upgrade.

Thanks for reply, right now i dont have any usb 3.0 device thats why i disable it.its already on Advance mode.

Today when i am return to home then enable fast boot from os end, then i share what happen.

still i didn't try hiren boot cd , i will try & inform you.

Hang only for first time when i start PC, after reset no issue.even after continues running for six hours.
 

patkim

Cyborg Agent
Ok, looks like your BIOS has options for EZ/Advanced mode switch, some BIOS's have simply a toggle switch. So all right.

Today when i am return to home then enable fast boot from os end, then i share what happen.
Please note that you have to Disable Fast Boot, not Enable the same. If you have never fiddled with this setting, most likely it may be enabled by default in Windows 10 or in case if it's incompatible with your BIOS it might not be available at all. However if you are referring to Reset (i.e. pressing the Reset Button) as Restart, then this setting might be ineffective, then problem might be elsewhere. However just give it a try disabling Fast Boot.

You will get slightly improved performance with USB 2 Mass storage Devices plugged into USB 3 ports when XHCI Hand-Off is enabled in BIOS.

poweroptions.png
 
Last edited:
OP
S

surya_sapui

In the zone
Ok, looks like your BIOS has options for EZ/Advanced mode switch, some BIOS's have simply a toggle switch. So all right.


Please note that you have to Disable Fast Boot, not Enable the same. If you have never fiddled with this setting, most likely it may be enabled by default in Windows 10 or in case if it's incompatible with your BIOS it might not be available at all. However if you are referring to Reset (i.e. pressing the Reset Button) as Restart, then this setting might be ineffective, then problem might be elsewhere. However just give it a try disabling Fast Boot.

You will get slightly improved performance with USB 2 Mass storage Devices plugged into USB 3 ports when XHCI Hand-Off is enabled in BIOS.

View attachment 18805



I disable Fast Boot from the operating system yesterday, Today when I start my pc then again hang the first time & freeze then after few seconds display gone after few minutes pc automatic reboot then when desktop comes after few seconds again freeze the after few seconds display gone. but this time pc didn't automatic reboot.

This need to manually reboot then after no issue.I want to know through event viewer if anything possible to know whats the actual issue.
 

patkim

Cyborg Agent
Few more things to try
1. Follow Clean Boot approach. Google how to configure clean boot if you are not familiar. (You can always later restore it back to Normal boot as required)
2. Downgrade/upgrade chipset and GPU drivers
3. You have many hardware components including multiple HDDs and RAM sticks. Try booting with minimum components i.e. just your system disk , one RAM and see if the issue persists. Remove unwanted components like if there's a separate sound card.
4. Create about 40 GB free space on one of your HDDs and try clean install of Windows 10 on that with just that drive connected, then install all drivers and software one by one and see where the issue get reproduced in case so.
 

topgear

Super Moderator
Staff member
@surya_sapui - What PSU are you using ? To drive all theses drives with a FX 8300 needs some serious power.

My hunch is one of the HDD having bad sector issue. Check HDD health with Crystal Disk Info software and post the screenshots here.
 
Top Bottom