HDD error or Grub2 issues?


Indian Railways - The Vibrant and Moving INDIA
The message showing while I am booting up:--->

error: (hd0) out of disk
Grub2 rescue>

Inside my BIOS settings,all the HDD'S are shown O.K. in their S.M.A.R.T check and other status are normal as usual...
What is the problem?

Has the Grub2 gone corrupted?
Last edited:


I have 2 HDDs - WD, Seagate.

The MBR was present on the WD HDD. When the booting priority was Seagate first and then WD - I got the same error as you.

I changed the hard disk priority so that the WD one boots first - Problem solved. Maybe it'll work for you too....

If not post the o/p of:

Grub2 rescue>ls


Indian Railways - The Vibrant and Moving INDIA
HDD is O.K. as mentioned by the parameters of Disk utility under Linux installation.
It was issue and problems relating to grub2,to be presumed.
I had to delete the Zorin Linux distro and freshly install Mint Linux-14(NADIA) which was also having issues.
Ultimately problem seems to be resolved.
Top Bottom