D-LINK ROUTER Querry !!!!

Not open for further replies.


Core i7 (nehalem) Owner
Well till yesterday my Router (D-Link ADSL Router 502-T) was owrking fine but then all of a sudden the net was not geting connected (the MTNL's TRIBAND 256 Kbps connection that i have),actually there was only one LED working and that was the POWER LED.

The STATUS and the ADSL Led's were not blinking.....indicating that either the net was down or the connection was not functioning from the MTNL's hub.

I tried calling up MTNL's so called helpline number for mumbai wich is 1504 for broadband querries.Well the dumb person told me that the ROUTER has gone bad and corrupt and now they will hv to change it with a new router,but i surely dont believe that,

I tried to reinstall the Router's drivers but wen my PC detects that the NEW HARDWARE FOUND as "NET",bt previously i got a msg wen i first installed the device onto my PC as NEW HARDWARE FOUND as D-Link Router (a month bac) and wen i tried to install the drivers from the FOUND NEW H/W WIZARD, the msg that i get is this...

THE WIZARD could not find the s/w on ur computer for ..."NET"

and wen i selece my CD ROM (where the D-Link installer cd is present in my F: ) then i get this msg....

The Location u specified does not exist or cannot be reached,please uncheck the "Include this location" in the search box or enter another location

And wen again if i try to manually install the drivers, i get the msg that there is no such s/w for ur current device on the specified location (wich is my CD ROM F:\) :? :? :?

I even tried removing and replacing the CMOS battery to see if there was any problem in the BIOS but even then the PC detectd my h/w as NET and not as D-Link Rputer/adapter for my network devices and im unable to install the drivers.

If i install the drivers directly by AUTO runningthe Cd then the D-Link drivers get installed on my PC but then the PC doesnt detect any Router on my system...plz suggest..wil suitable answers or suggestions guys !!! :?

I hv a WINXP Prof edition (pirated version) with no SP2 on it.
with 256 MB (DDR266) Hynix RAM,
With nVIDIA Ge Force FX 5200 FX (256 MB DDR RAM) AGP CARD,

cheers n e-peace......:(:(


Core i7 (nehalem) Owner
cybershastri wrote:

I think the router has gone bad..Change it!!
Ru really sure abt it bro !! :? well as it is my D-Link Router is in the warranty period as the Date of Purchase is 3/5/2005 so i can very well send it to the D-Link ppl...but any how Ru really sure that this is the only caes wen the Router goes bad?? I mean if it does not show the STATUS LED in ON state (the Power led is in an ON state) does that mean that the router is gone bad ! :? Plz do let me know if this caes is a true indication of a Router going bad (not working condition) :?

cheers n e-peace.....


^^ In your post you have said that windows is not detecting (or detecting it as 'NET') the router now. But previously it was detecting. Also trying to install the drivers directly from the CD is not solving the problem. So there is a good chance that it is a hardware problem. Even if it is not a hardware problem, whats the problem in changing it? Any ways you dont have to pay any money for changing it. They usually chage it in a reasonably short time. If it takes long time then they would give you a standby router.
Not open for further replies.
Top Bottom