• CONTEST ALERT - Experience the power of DDR5 memory with Kingston Click for details

Connecting 2 PCs wirelessly with D-Link DSL-2730U wi-fi router

Hi,

How do I wirelessly connect my 2 PCs to a modem+router such that the pc to pc browsing is isolated from the internet connection (WAN)?

In detail:
I recently purchased a D-Link DSL-2730U modem router to replace my bsnl wired modem, the idea being to connect my 2 PCs wirelessly (to share files between the two and maybe even play games between the 2 PCs). PC1 is running XP SP-3, and PC-2 is running Windows 8.

I installed the 2730U yesterday. I followed the setup instructions (using all default values, except for my username and password) and soon had the two PCs talking to each other. :) . I wanted to ensure two things: a) that the two PCs could communicate even without the LAN connection between PC1 and the router, and b) that the two PCs were communicating locally (via the LAN) and not via the BSNL Internet connection (WAN).

To test it out, I first disconnected the Ethernet cable between PC1 and the router. (BTW, PC2 is only connected wirelessly.) The 2 PCs could communicate between themselves and also I could browse the internet from both PCs (via the router). I then disconnected the WAN port. The 2 PCs could still talk to each other. This was great! It meant my two PCs were communicating via the wireless LAN and no data was being sent out on the Internet connection.

However, this morning, when I switched on my PC1, it refused to connect wirelessly to the router. Even PC2 refused to connect. I even waited for a few minutes (so that things could stabilise) and tried again, but it was of no use. I couldn't even access the router (198.168.1.1). Finally, having no other alternative, I re-connected the LAN cable from PC1. Thereafter, I was again able to connect wirelessly as before. However, I now notice that whenever I browse one PC from the other, the Internet LED on the router is flashing, which means that the data is being routed through the BSNL connection (or internet).

To ascertain, I disconnected the WAN cable -- and found that the two PCs could not talk to each other!

My questions are:

a) When it all worked properly as desired last night, does anyone have any idea why did it not connect wirelessly this morning? Why did it force me to use the cable before connecting wirelessly?

b) While the 2 PCs communicated independently last night, why are they communicating via the Internet connection today?

c) By setting it up the way I have, is the wireless LAN separate from the Internet/WAN connection (though both are on the same router) or will other BSNL users be able to access my local shares?

d) Also, on PC2 (Windows 8), while setting up the wireless connection, I put it as "Private Network". Is this okay, or should I change it to "Public Network" (since I'm also using the same wireless connection to access the Internet as well)? If so, how can I change the Network type to Public Network?

e) I was earlier using the USB connection on my BSNL modem to connect PC2 to the internet and had connected the 2 PCs wirelessly using a PC-to-PC ad-hoc connection. (Though not very secure it met my needs, as I only used/activated this connection on weekends to backup files from PC1 to PC2.) At that time, PC2 was actually a laptop and it had Windows 7. In Networks and Sharing, it showed two connections -- on Internet and one Private.

However, I recently sold the laptop and purchased a PC (which came with Windows 8) and Windows 8 doesn't allow ad-hoc PC-to-PC connections. Hence I was forced to go in for a router. Now, with my current set-up as described above, Network and Sharing shows just one connection -- the wireless connection (and it's marked as Private as I've explained above); it doesn't show the WAN connection though the WAN connection is on the same router. is this alright? Or have I made a mistake in my setup?

I'd be grateful if someone can give me proper advice on how to set it up so that PC1 and PC2 can communicate wirelessly through the router and also browse the Internet (so that I can eliminate the LAN cable between PC1 and the router), but at the same time keep the PC-to-PC communication from going via the Internet connection.

Thanks.
Sunil
 

whitestar_999

Super Moderator
Staff member
it seems that you messed up your network settings.first of all run ipconfig /all command in command prompt on both pc when connected by wifi & then run the command on pc connected by lan & post all results here.
 
OP
S

ss786@vsnl.com

Broken In
it seems that you messed up your network settings.first of all run ipconfig /all command in command prompt on both pc when connected by wifi & then run the command on pc connected by lan & post all results here.

Hi Whitestar, thanks for resonding.

I'm a little wary about publishing my network details on this open forum. Can you tell me what I should be looking for in the settings? (I have many years of computing experience--right from the days of DOS :) so don't worry about talking jargon; I'll understand most of it. It's just that I don't have any networking experience as this is the first time I'm trying to set up a network, and that too a wireless one!)

Sunil
 
Last edited:
OP
S

ss786@vsnl.com

Broken In
whitestar_999: thanks for responding to my query.

I changed the Channel setting to "Auto" and my connection is working fine now. Earlier, the connection did not work when it was set to "Channel 6". Does anyone have any idea why?

Regarding the other doubts I had, again, everything seems to be working fine now (and I have no idea what changed and why it is working now, when it didn't earlier). The two PCs can connect to each other even without the internet connection; the pc to pc wifi traffic is not passing through the internet gateway (meaning, the two PCs can talk to each other even when I've disconnected the phone line from the router). Again, I have no idea why that one day, the traffic was going through the gateway. [The only change I made was reset the Channel to "Auto".]

The only small problem I'm facing now is when I switch off the router at night and switch it on the following morning, sometimes it doesn't connect properly to the internet. Nothing seems to work. I then switch off and on the router again and everything becomes alright again. Does anyone have any idea why this happens?

Sunil
 
Top Bottom