Celkon A35k - OS does not understand to install apps on SD card


Cyborg Agent
I am temporarily using my spare Celkon A35K mobile. It's low quality phone with just 256MB internal storage.
I have inserted 4GB microsd card in there and it's detected properly too. It shows free space of some 3.7GBs for the SD card.

There's a setting to install new apps to either SD card or Internal or let system decide. This is set to SD card.
Still when I download app from google play, it shouts that there's not enough storage.

Do I need any more settings? I have tried clearing cache and data from google play, still no effect. Reformatted SD card too.

Somehow OS (KitKat) does not seem to understand to install new apps to SD card. Any more things can I try?

Bluetooth file transfer works correctly from Windows laptop to the phone and there OS puts the file correctly to SD card, the issue seems to be only with Apps installation.

Last edited:


Chosen of the Omnissiah
Android kitkat and newer versions has restricted sdcard write permission for 3rd party apps.*

Source:*Fix SD card write permission in Kitkat and Lollipop

Sent from my Lenovo K33a42 using Tapatalk


Cyborg Agent
Well then looks like the setting allowing users to choose the location of New Apps is simply meaningless!
It has no effect on how OS handles Apps installation even if user selects SD card as location of apps.
Top Bottom