AMD64 packages not installing!

Discussion in 'Open Source' started by blueshift, Jul 31, 2009.

Thread Status:
Not open for further replies.
  1. blueshift

    blueshift Wise Old Crow

    Joined:
    Apr 17, 2005
    Messages:
    1,227
    Likes Received:
    17
    Trophy Points:
    0
    Location:
    Inside the Pixel
    Hello,
    My system is Athlon 64 X2 based and using Ubuntu 9.04. The uname cmd gives this:
    Code:
    Linux blueshift-desktop 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux
    I downloaded some amd64 architecture based packages from Ubuntu site. But it says 'Wrong architecture amd64' when i try to install. The corresponding i386 architecture version is installing without any problems. Also the same i386 package is giving similar error about architecture on my friends system which is Intel DualCore based.
    Why is their architecture mismatch? Why does it not supoort amd64 packages?
     
  2. desiibond

    desiibond Bond, Desi Bond!

    Joined:
    Oct 9, 2007
    Messages:
    9,754
    Likes Received:
    9
    Trophy Points:
    0
    Location:
    Bangalore
    if you are thinking of installing 64-bit packages, you need to have a 64-bit Operating System.

    Looks like you downloaded x86-64 packages for your 32 bit OS, which won't work.
    Same way, it seems that your friend is using 64 bit kernel and hence x86 packages won't work.
     
  3. NucleusKore

    NucleusKore TheSaint

    Joined:
    Jun 19, 2004
    Messages:
    3,435
    Likes Received:
    2
    Trophy Points:
    0
    Location:
    Antigua
    ^Yes

    You have to install 64 bit Ubuntu to use 64 bit packages. The output of uname -a for me is

    Linux neville-desktop 2.6.28-14-generic #47-Ubuntu SMP Sat Jul 25 01:19:55 UTC 2009 x86_64 GNU/Linux
     
  4. OP
    OP
    blueshift

    blueshift Wise Old Crow

    Joined:
    Apr 17, 2005
    Messages:
    1,227
    Likes Received:
    17
    Trophy Points:
    0
    Location:
    Inside the Pixel
    Isn't the 9.04 Jaunty 64-bit version? I got the CD from shipit.
     
  5. OP
    OP
    blueshift

    blueshift Wise Old Crow

    Joined:
    Apr 17, 2005
    Messages:
    1,227
    Likes Received:
    17
    Trophy Points:
    0
    Location:
    Inside the Pixel
    Ok. I searched. I may be having the 32-bit CD.
    Another query.. will the amd64 packages install on my friends PC?
    Is IA64 package for Intel dualcores?
     
  6. desiibond

    desiibond Bond, Desi Bond!

    Joined:
    Oct 9, 2007
    Messages:
    9,754
    Likes Received:
    9
    Trophy Points:
    0
    Location:
    Bangalore
    IA64 I think is for Intel Itanium and not for intel c2d. for c2d, it should be ix86 or x86-64
     
  7. NucleusKore

    NucleusKore TheSaint

    Joined:
    Jun 19, 2004
    Messages:
    3,435
    Likes Received:
    2
    Trophy Points:
    0
    Location:
    Antigua
    I have an AMD Athlon X2
    use the amd64 iso
     
  8. OP
    OP
    blueshift

    blueshift Wise Old Crow

    Joined:
    Apr 17, 2005
    Messages:
    1,227
    Likes Received:
    17
    Trophy Points:
    0
    Location:
    Inside the Pixel
    ok. In Ubuntu site, there were only 2 options: AMD64 and other is i386.
     
  9. phreak0ut

    phreak0ut The Thread Killer >:)

    Joined:
    Apr 2, 2006
    Messages:
    1,181
    Likes Received:
    6
    Trophy Points:
    0
    Location:
    Bangalore
    You can install the 64-bit version if its a 64-bit processor. So, Intel or AMD, 64-bit should work fine.
     
Thread Status:
Not open for further replies.

Share This Page