32GB SD card detected in PC but not in mobile


Broken In
I purchased new Strontium 32 GB Class 10 SD card. Formatted in FAT32 thorugh Windows7 and used it in mobile (YU Yureka)
After 3-4 days mobile stopped detecting the card. I tried from many file viewer but mobile didn't detect the card.
Then on PC it was getting detected as normal and I was able to view all files and also able to do operations like copy and paste. But when I tried to see properties of card it dismounts and shows 0 bytes used and free space and card. Then if I again re plug the card reader, Pc again detects the card normally. Problem occurs only when I want to see the properties. I checked the card through cmd/chkdsk it shows OK. Pc shows file system as FAT32 still.What can I do?


The Power of x480
Staff member
You are gonna have to do more tests.
Try to use another card reader, another USB port (maybe ports at the back of cabinet), try another phone etc...
Even try to use it on a linux distro...


WD Official
Hi [MENTION=13073]anvesh[/MENTION],

I agree with vyom. Based on your post, it may be a hardware issue. I’d like to check with you, did you try to format your card? To confirm the possible reason, please run manufacturer utility software in your system to test the card condition.

If the result is bad or the card is not detectable, so I’d suggest you to proceed for an replacement.

Hope it helps.
Top Bottom