Wi-Fi module not showing up

Status
Not open for further replies.

RCuber

The Mighty Unkel!!!
Staff member
I got a weird issues with my HP Omen 15.
The Wifi module is not been detected by either windows or linux.

What happened
1. Hibernated my computer yesterday night.
2. Switched on the laptop this morning.
3. Windows update was installed overnight, as I got into a clean desktop instead of my work.
4. Everything was working so I continued my work.
5. Took a break
6. Laptop went into sleep mode
7. Came back and woke up the laptop
8. No internet
9. No AP showing up in list
10. Airplane mode is grayed out
1611085247546.png

11. Device not showing up in device manager
12. Checked bios/diagnostics check - Wireless Module Passed, WWLAN Module: NOT INSTALLED
13. msinfo32.exe
1611085515517.png


14. wmic.exe output

Bash:
AdapterType     AdapterTypeId  AutoSense  Availability  Caption                                               ConfigManagerErrorCode  ConfigManagerUserConfig  CreationClassName     Description                                DeviceID  ErrorCleared  ErrorDescription  GUID                                    Index  InstallDate  Installed  InterfaceIndex  LastErrorCode  MACAddress         Manufacturer  MaxNumberControlled  MaxSpeed  Name                                       NetConnectionID  NetConnectionStatus  NetEnabled  NetworkAddresses  PermanentAddress  PhysicalAdapter  PNPDeviceID                                                     PowerManagementCapabilities  PowerManagementSupported  ProductName                                ServiceName   Speed                Status  StatusInfo  SystemCreationClassName  SystemName     TimeOfLastReset
                                          3             [00000003] Intel(R) Wi-Fi 6 AX200 160MHz                                                               Win32_NetworkAdapter  Intel(R) Wi-Fi 6 AX200 160MHz              3                                                                                 3                   TRUE       17                                                              0                              Intel(R) Wi-Fi 6 AX200 160MHz                                                                                                    FALSE                                                                                                         FALSE                     Intel(R) Wi-Fi 6 AX200 160MHz                                                                     Win32_ComputerSystem     xxxxxx-LAPTOP  20210120000149.500000+330

I cannot roll back any thing at the moment as I have pending work. I can use ethernet/usb tethering for backup.
I will have to contact HP Support in the morning to resolve the issue.

Any idea if the module is dead?

cc @whitestar_999
 

whitestar_999

Super Moderator
Staff member
Just for future reference, always restart win 10 manually after any update no matter how small it is(except for windows defender updates maybe) or how it was installed(aka auto-update). I have noticed that many weird issues may come up if system is not restarted after some windows update & being used for hours/days(using sleep/hibernation).
 
Status
Not open for further replies.
Top Bottom