Laptop not starting, no led, no battery charge indicator

Discussion in 'Hardware Q&A' started by arijitsinha, Oct 12, 2017.

  1. arijitsinha

    arijitsinha ﴾͡๏̯͡๏﴿ O'RLY?

    Joined:
    Nov 23, 2011
    Messages:
    1,946
    Likes Received:
    4
    Trophy Points:
    38
    Location:
    ..
    So last week I found some ants coming out of my laptop(It happened before as well) so I ignored them and started the laptop. After sometime it turned off on its own, I switched on again, but after some time it turned off. This happened 2-3 times.

    Later it is not even starting. When I pressing the power button nothing is happening, no power indicator, hdd, battery light is lighting up. No sign of life.

    I have opened the laptop and cleared all the ants now.

    • I removed the battery and tried to switch it on with AC power connected.
    • Removed AC power and tried to switch on battery inserted.
    • Removed battery and AC power, then held power button for 1 minute, later connected AC power and tried switching on, but still no sign.

    Can someone help me find out the issue? Most probably the motherboard have been short circuited, but is it possible due to the ants? I don't see any burnt sign on the motherboard.
    • How can I be sure that the motherboard gone wrong.
    • If the motherboard is short circuited, is it possible to repair it? or do I have to order a new motherboard?

    I don't want to go to service center as it is out of warranty.
    Laptop Model is Sony VAIO VPCCB45FN.
     
  2. patkim

    patkim Member

    Joined:
    Mar 5, 2005
    Messages:
    712
    Likes Received:
    17
    Trophy Points:
    18
    Location:
    Mumbai,Pune
    On my Asus Laptop I had a similar issue that laptop would not start. I tried most of the tricks as what you did but it would refuse to start.

    I had no choice but to take it to service center even though it was out of warranty.
    I was told that the issue could be in motherboard or the IO Board. Fortunately they replaced the IO Board and hence it did not cost me much.

    Since you have tried most of the tricks and you seem to be comfortable opening your laptop, I suggest you also try the following
    - Directly spray IPA cleaner on the board. just in case any dirt has accumulated on some component it will dissolve away
    -If RAM is not integrated, remove / re-insert RAM a few times. My Vaio netbook gave me starting troubles and RAM re-insert worked once.
     

Share This Page