Help in wifi issue


Democracy is a myth
Hi, coming with a peculiar issue here.

I'm unable to pull from gitlab when connected to Home broadband wifi.
git pull --rebase
and getting this error,

ssh: connect to host <can't divulge host address here>: Connection timed out
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

However the same command works withoug any issue when I'm connected to either JIO or Airtel hotspot.

Can you guys help me anyway to fix this?


Cyborg Agent
I have never used Git and don’t know how it works. Just making some guesses here. I am not sure if you are using Windows or Linux.

Looks like you are using git command over SSH? If so, does it offer running over any other protocol? If so, did you try switching to that protocol?

What if you put your computer in DMZ? Bypass all firewalls and port forwarding requirements of your router?

Who is your ISP and do they offer you Public IP or do they put you behind CGNAT? Do Jio & mobile hotspot give you IPv6?

While on ISP’s network, just try using some VPN bypassing that ISP’s firewall. For example, you can try F-secure Freedom VPN. It’s fully functional for first 5 days before you need to pay. What if you use VPN and connect to some remote server outside India and then virtually from there execute the same commands while still tunneling thru the same ISP? Does it go thru this time? If so it’s possible that ISP may be blocking some inbound ports on which these protocols run. Just a guess. Many ISPs block several inbound ports mostly 1023 & below. Generally, they are supposed to keep ephemeral ports open or else regular Internet traffic will get blocked but they might on purpose block certain ports like 22, 80 etc

You can try netstat commands or even Windows 10 built in resmon.exe to check the active connections and port they are using.
Last edited:


I am the master of my Fate.
^^I don't think ISP will block ports. They will only block the domain IP addresses.
port blocking is done by organizations for more security & compliances policies


Democracy is a myth
So far tried these that did not work

Changed DNS
Tried to use alternate port 443 for SSH

My NW setup is this way,

Broadband -->Normal Router-->Mesh router-->Office laptop-->Office VPN-->Github (fails Git pull here)

With Hostspot this way,
Hotspot-->Office laptop-->Office VPN-->Github (git pull works fine here)


The Slowest One

have you tried the solutions here? How about using https instead of ssh as your git repo url?


Democracy is a myth
Above option asks to use alternate port 443 for SSH connection.

Tried to use alternate port 443 for SSH

AS told above, did not work.
However, the solution is for Github, I'm using Gitlab.

Gitlab website asks to use a diff. way for using 443, that too failed :(


Broken In
How can I get help with my Wi-Fi?
How to improve your internet speed
Turn things off and on again.
Move your router to a better location.
Switch your Wi-Fi frequency band.
Adjust your router's antennas.
Extend your Wi-Fi network.
Prune unnecessary connections.
Change your Wi-Fi frequency channel.
Upgrade to faster internet.

Top Bottom