D-link DIR-605L and reliance broadband issue


Broken In
Well, I recently started using this D-link router for my reliance connection (Previously used it for a PPPoE connection and it worked flawlessly).
When I first connected my cable to router and tried to open reliancebroadband.co.in (on which reliance user have to log in in order to use internet), it didn't open. I thought it as some DNS issue and tried searching internet for reliance broadband's DNS server address. I set that and it opened. After this i just tried for automatic DNS adress by having there in field and it worked again. I checked the DNS address in connection properties and it was same as the address which i got from the internet.
My problem is that some time ago when my log in expired on reliancebroadband.co.in, i tried to log in again and i got stuck in the same problem, i just couldn't open the page. I tried opening it without router and it opened without taking any time although the automatic DNS acquired by computer and router were both same. Then what is causing this?
Its opening again with my router but it is very irritating to be unable to open the log in page for some random reason.

Anyone else using same router with reliance broadband connection, please let me know your router settings.
Top Bottom