Win xp tweaks for max performance

Discussion in 'Tutorials' started by blademast3r, Oct 19, 2006.

Thread Status:
Not open for further replies.
  1. blademast3r

    blademast3r New Member

    Joined:
    Sep 5, 2006
    Messages:
    431
    Likes Received:
    2
    Trophy Points:
    0
    Location:
    Island of Time
    REMEMBER ALWAYS BACKUP YOUR SYSTEM FIRST BEFORE U CHANGE ANYTHING AND USE THE GUIDE AT YOUR OWN RISK, thanks)

    To increase system performance

    Right click my computer. Click properties.
    Click advanced.
    Click settings (under performance).
    Click Adjust for best performance.
    Scroll to the bottom and check the last one “use visual styles on windows and buttonsâ€Â￾.

    These Settings will fine tune your systems memory

    You need at least 256MB of ram to do this:

    Go to start\run\regedit -and then to the following key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Session Manager\Memory Management

    1.DisablePagingExecutive -double click it and in the decimal put a 1 - this allows XP to keep data in memory now instead of paging sections of ram to harddrive yeilds faster performance.

    2.LargeSystemCache- double click it and change the decimal to 1 -this allows XP Kernal to Run in memory and improves system performance a lot.

    3.Create a new dword and name it IOPageLockLimit - double click it and set the value in hex - 4000 if you have 128MB of ram or set it to 10000 if you have 256MB set it to 40000 if you have more than 512MB of ram -this tweak will speed up your disckcache.

    Reboot

    Tweak The Swap File

    For Users with 256 MB RAM or more this tweak will boost their Windows- and Game-Performance.
    What it does: It tells Windows not to use any Swap File until there is really no more free RAM left.

    Open the System Configuration Utility by typing msconfig.exe in the RUN command. There in your System.ini you have to add "ConservativeSwapfileUsage=1" under the 386enh section.

    Restart your Windows and enjoy better Game performance

    Disable Services

    XP Pro runs a lot of services by default that are pointless if your not on a corporate network, the following services are ones that I safely disable thereby freeing up memory but check what each one does first to make sure your not using it for something:

    Go to Run and type services.msc, right click on each service, properties and choose disable.

    Alerter
    Application Management
    Automatic Updates
    Background Intelligent Transfer
    Clipbook
    Distributed Link Tracking Client
    Distributed Transaction Coordinater
    Error Reporting Service
    Fast User Switching Compatibility
    IMAPI CD-Burning
    Indexing Service
    IPSEC Services
    Messenger
    Net Logon
    Net Meeting
    Remote Desktop Sharing
    Network DDE
    Network DDE DSDM
    Portable Media Serial Number
    Remote Desktop Help Session Manager
    Remote Registry
    Secondary Logon
    Smartcard
    SSDP Discovery Service
    Telnet Themes
    Uninterruptible Power Supply
    Universal Plug and Play Device Host
    Upload Manager
    Webclient
    Wireless Zero Configuration
    WMI Performance Adaptor


    Speed Up The File System

    NTFS is a great file system, but its feature-set comes at a slight cost in performance. You can negate this a little with the following tips:

    * By default NTFS will automatically update timestamps whenever a directory is traversed. This isn't a necessary feature, and it slows down large volumes. Disable it by going to Run and type regedit:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\FileSystem and set 'DisableNTFSLastAccessUpdate' to 1.

    * NTFS uses disparate master file control tables to store filesystem information about your drives. Over time these core MFT files grow and become fragmented, slowing down all accesses to the drive. By setting aside a little space, MFT's can grow without becoming fragmented.

    In the same key where you disabled the last access feature creat a new DWORD value called 'NtfsMftZoneReservation' and set it to 2.


    Disable DLL Caching

    Windows Explorer caches DLLs (Dynamic-Link Libraries) in memory for a period of time after the application using them has been closed. This can be an inefficient use of memory.

    1. Find the key [HKEY_LOCAL_MACHINE\SOFTWARE\Mcft\Windows\Curr entVersion\Explorer].

    2. Create a new DWORD sub-key named 'AlwaysUnloadDLL' and set the default value to equal '1' to disable Windows caching the DLL in memory.

    3. Restart Windows for the change to take effect.


    Tweak The Prefetch

    1. Run "Regedit"
    2. Goto [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Session Manager\Memory Management\PrefetchParameters\EnablePrefetcher]

    3. Set the value to either 0-Disable, 1-App launch prefetch, 2-Boot Prefetch, 3-Both ("3" is recommended).

    4. Reboot.

    It will decrease the boot time but double and increase the performance of your XP.


    SpeedUp Your Connection By 20% (Cable/DSL Users Only)
    1.Log on as "Administrator".
    2. Run - gpedit.msc
    3. Expand the "Local Computer Policy" branch.
    4. Then expand the "Administrative Templates" branch.
    5. Expand the "Network" branch.
    6. Highlight the "QoS Packet Scheduler" in left pane.
    7. In the right window pane double-click the "Limit Reservable Bandwidth" setting.
    8. On the settings tab check the "Enabled" item.
    9. Change "Bandwidth limit %" to read 0.
    10. Then go to your Network connections Start=>Control Panel>Network & Internet connections>Network Connections and right-click on your connection. Then under the General or the Networking tab, (where it lists your protocols) make sure QoS packet scheduler is enabled.

    It may take effect immediately on some systems. To be sure, just re-boot.
     
    busyanuj likes this.
  2. drsethi

    drsethi New Member

    Joined:
    Jan 29, 2004
    Messages:
    220
    Likes Received:
    4
    Trophy Points:
    0
    Location:
    Amritsar
    Most of the tips are already known but good for new users
     
  3. OP
    OP
    blademast3r

    blademast3r New Member

    Joined:
    Sep 5, 2006
    Messages:
    431
    Likes Received:
    2
    Trophy Points:
    0
    Location:
    Island of Time
    Thats the whole point...
     
  4. rakeshishere

    rakeshishere HELP AND SUPPORT

    Joined:
    Jun 9, 2006
    Messages:
    1,604
    Likes Received:
    30
    Trophy Points:
    0
    Plz post the source from where u copy-pasted this stuff and this tut is good for all noobz:(
     
  5. OP
    OP
    blademast3r

    blademast3r New Member

    Joined:
    Sep 5, 2006
    Messages:
    431
    Likes Received:
    2
    Trophy Points:
    0
    Location:
    Island of Time
    Its from a rival magazines forum... ahem...u want me post the link
     
  6. essarrenn

    essarrenn New Member

    Joined:
    Oct 21, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    :mad: :mad: :mad: :mad: :mad:

    My Windows XP SP2 takes to boot 2 minutes. Why this is happening? In the startup antivirus and firewall only running. And I have stopped most of the services. I was using bootvis and tune-up utilities 2006 for fast bootup. But there is no difference.

    Anyone Know the exact reason for slow booting?

    My System configuration P IV - 3 GHz, 512 MB RAM, 80 GB HDD, Windows xp sp2

    :p :p :p :p :p
     
  7. satyamy

    satyamy Alive Again...

    Joined:
    May 20, 2005
    Messages:
    1,665
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    Mumbai
    good for Newbies
     
  8. Tech Geek

    Tech Geek Wise Old Owl

    Joined:
    Sep 21, 2006
    Messages:
    1,602
    Likes Received:
    18
    Trophy Points:
    0
    Location:
    Cyber Hell
    My PC takes about 5 minutes to boot
     
  9. Stalker

    Stalker New Member

    Joined:
    Jul 16, 2006
    Messages:
    992
    Likes Received:
    3
    Trophy Points:
    0
    Location:
    closer than u think..
    try disabling ur antivirus & firewall.......also scan ur computer 4 adware/spyware
    2 min is actually a gud time 4 windows to boot
     
Thread Status:
Not open for further replies.

Share This Page