The ~`^' problem

Status
Not open for further replies.

fun2sh

Pawned!... Beyond GODLIKE
i use windows vista home premium on my acer 4710 laptop.
the problem is that wen i press any of these keys - ~`^' anywhere (where i can type) then those respective symbols dont appear on screen until i press any other key. i tried typing these symbols everywhere be it on this forum reply box,notepad n even command prompt but those symbols appears only after i type any other character.

for ex- if i press ` then it will appear only wen i type any other character like a c <spacebar> or the same (or 1among those) keys.

but wen i type these characters in Turbo c++ (it works in vista) then they appears instantly n every key stroke is normal.

is there any bug in vista. DO ANY1 OF U EXPERIENCED THIS????
 
OP
fun2sh

fun2sh

Pawned!... Beyond GODLIKE
no yaar i didnt change any settings.
i reinstalled vista day before yesterday only and this problem was then too.
 

vish786

"The Gentleman"
acer customer cares suck badly, i had to scold them (use words ) for rude behaviour & not responding properly towards customers.
 

infra_red_dude

Wire muncher!
Jus change the locale/keyboard layout to US English (or experiment with US International etc.) That will solve the problem, mostly.
 
OP
fun2sh

fun2sh

Pawned!... Beyond GODLIKE
firstly its not the problem of my laptop keyboard coz as i said those keys works fine wen i type in turbo c++ editor window in vista.
secondly my keyboard layout is in US international format itself and i tried changin to some other layouts too but it didnt help.
ONE MORE THING, THE MANY QUESTION I HAV POSTED ON THIS FORUM OUT OF WHICH ONLY 2-3 HAS BEEN SOLVED :sad:
 

infra_red_dude

Wire muncher!
turbo c++ works in NT virtual mode for dos apps. When I had this problem in XP I just experimented with the keyboard layout. Finally setting it to US English and playing around wid the Locale settings solved it for me. its not a hardware problem. I had this problem in Ubuntu too. Changing the keyboard layout here, solved the problem again.
 

Sykora

I see right through you.
infra_red_dude is right, it is the locale. It waits after you press ~ or ^ because those are used to create accented characters in some locales. Changing it to US en will fix the problem.
 
OP
fun2sh

fun2sh

Pawned!... Beyond GODLIKE
Problem solved by changing the keyboard layout from US INTERNALTIONAL to US.

u guys didnt tell that the RESTART is also required for changin to take place!! so it was not workin for me. now i tried restartin n THE PROBLEM IS SOLVED!!

MODS can lock this thread to prevent unnnecessary CHIT-CHAT N THREAD BUMPIN!! :razz:
 
Status
Not open for further replies.
Top Bottom