problem with asus A8N-E and debian

Not open for further replies.


I am facing a problem with playing audio in my debian installation.
my motherboard is asus A8N-E with the nforce-4 ultra chipset, and i am using the onboard audio.
first i tried alsa to configure the sound card, but it couldnt detect it.
then i downloaded the nforce chipset driver for linux from the nvidia website and from there i installed the audio driver.
what the driver does is that it creates a kernel module called nvsound and inserts it into the kernel tree to be loade during booting. after creating the module some configurations needed to be done. here is what it said in th readme that accompanied the driver.
Module Configuration File Location

Module configuration files are different for 2.4 and 2.6 series kernels. The various Linux distributions also differ in how they handle module configuration.

* For distributions based on a 2.4 series kernel, the module configuration file is typically called /etc/modules.conf.

* For distributions based on a 2.6 series kernel, the module configuration file is typically called /etc/modprobe.conf. Some distributions use a subdirectory, /etc/modprobe.d/ , to hold individual configuration files for sound modules, etc.
there was no editable file in /etc/modprobe.d, so i considered that i had to llok into the /etc/modutils directory.
If the distribution you are using provides a configuration mechanism for audio drivers, use it to select the nvsound driver module for use with the nForce audio device. Otherwise, manually edit the module configuration file.

If your configuration file already contains an entry for the i810_audio or snd-intel8x0 drivers (open-source audio drivers that supports the nForce audio controller), that entry needs to be commented out with a # or removed:

# alias sound-slot-0 i810_audio

Add the following lines to the configuration file:

alias sound-slot-0 nvsound
alias snd-intel8x0 off
alias i810_audio off

On some distributions, you may need to replace sound-slot-0 with snd-card-0.

If you wish to have nvmixer audio settings automatically restored each time the nvsound driver loads, add the following lines to the configuration file for 2.4 kernels:

post-install nvsound sleep 1; /usr/bin/nvmix-reg -f /etc/nvmixrc -L >/dev/null 2>&1 ||:
pre-remove nvsound /usr/bin/nvmix-reg -f /etc/nvmixrc -S >/dev/null 2>&1 ||:

For 2.6 kernels:

install nvsound /sbin/modprobe --ignore-install nvsound ; sleep 1; /usr/bin/nvmix-reg -f /etc/nvmixrc -L >/dev/null 2>&1 || :
remove nvsound { /usr/bin/nvmix-reg -f /etc/nvmixrc -S >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove nvsound

For both 2.4 and 2.6 kernels, you should add the following code to /etc/rc.d/init.d/halt, or /etc/init.d/halt.local on SuSE distributions. On Mandriva distributions, add the code at the end of function stop_mixer() in /etc/rc.d/init.d/sound.

if grep -q "\(nvsound\)" /proc/modules && [ -x /usr/bin/nvmix-reg ]; then
/usr/bin/nvmix-reg -f /etc/nvmixrc -S >/dev/null 2>&1

(In /etc/rc.d/init.d/halt, this code is best located next to any existing code that saves ALSA mixer settings.)

For Red Hat Enterprise Linux 4, Fedora Core 3 and later, add the following line in /etc/rc.local:

/usr/bin/nvmix-reg -f /etc/nvmixrc -L >/dev/null 2>&1

i added the said lines in the alsa-base file, and also the code for restoring the nvmixer audio settings during boot.

but i must have made a mistake, coz i cant play audio..:-(

the module nvsound is loaded successfully during boot, but i whenever i try to play a an audio says sound card not found..

what did i do wrong?


all files in /etc/modprob.d are editable..u must have tried editing the /etc/modprob.conf.

i think u should add the lines in the file alsa-base of /etc/modprobe.d.
also u should comment out the lines at the bottom of the file where it tries blocking third party modules from loading a sound driver.

hope this helps..
post what happens.
Not open for further replies.
Top Bottom