Problem in installing mplayer in fedora3

Not open for further replies.
Not Able to install Mplayer for linux
I started by downloading all codecs by comanding
cvs login
cvs -z3 co ffmpeg/libavcodec

A directory named 'ffmpeg'
with a subdirectory named 'libavcodec' inside is created

but My problem starts here cant load all the codecs as mplayer help has written
STEP2: Installing Binary Codecs

MPlayer and libavcodec have builtin support for the most common audio and video
formats, but some formats require external codecs. Examples include Real, Indeo
and QuickTime audio formats. Support for Windows Media formats except WMV9
exists but still has some bugs, your mileage may vary. This step is not
mandatory, but recommended for getting MPlayer to play a broader range of
formats. Please note that most codecs only work on Intel x86 compatible PCs.

Unpack the codecs archives and put the contents in a directory where MPlayer
will find them. The default directory is /usr/local/lib/codecs/ (it used to be
/usr/local/lib/win32 in the past, this also works) but you can change that to
something else by using the '--with-codecsdir=DIR' option when you run

this configure command is not working at all
so can anyone help me out with simple method of installing mplayer with codeds
as i am a newbie to llinux
thx in advance


FooBar Guy
1) Make sure that you have GCC and some devel libraries installed.
2) Download MPlayer sources.
3) Download Win32 codecs and place then in appropriate directories. [ /usr/local/lib/codecs/ ]
4) compile MPlayer
$ ./configure --prefix=/usr/local/ --enable-gui --with-codecsdir=/usr/local/lib/codecs 
$ make
$ make install
$ make clean
now mplayer will get your MPlayer started. You'll also have to download Mplayer skins to get your GMplayer started.
Not open for further replies.
Top Bottom